No Container is start

Sir my xibo was working fine but i have restarted my pc. When i run docker-compose start it shows
“no container to start”. My all kind of data is still there i am unable to do anything. In my opioion (Google around) to perform docker-compose up it will delete my all old data or it will fetch all my pervious data . I need your help In this case

You need to make sure you’re in the correct directory (where your docker-compose.yml file is located) when you run docker-compose start.

If it still says there is no container, then assuming your data is correctly on disk inside shared/cms/library then you should run docker-compose up -d and it will create new containers, referencing your existing data.


I have docker-compose up -d run this command it is pulling sql data and xmr so my data will be there?

Your data should all be in the shared directory. I did suggest you check that before running the up command.

Sir Alex,

my process has been started but i cant see my login page it shows no page.

Sir Alex,

May i need to do docker-compose up instead of docker-compose up -d because last time docker-compose up -d shows same error i am facing now.

The containers take time to fully start. You need to be patient.


how to take full system backup so in case we deploy new xibo so that we have some backup to import and things goes smooth please help me out in this.

Stop the containers, and backup the shared directory, config.env and your docker-compose.yml file (or alternative if you’re using one of the other templates). That’s all you need. Then start the containers again.


Does it will get all the configurations data and templates as well we have to upload it again or just run docker-compose up command ? i am confused at this point.

Assuming the CMS was setup correctly originally, then all your data is inside the shared directory. Assuming you stop the container, and back that up, you have everything you need to restore on a different machine.