New install please help

I am not sure what I have done correct or wrong or if I missed steps etc. Below I will outline what I have done so far and where I am at but bottom line I cant get the player to sync to the CMS

I downloaded the docker tool because I am using windows 10 NOT pro. The docker tool installed fine and the hello-world worked fine.
I downloaded and extracted the xibo file and it currently sits at
C:\Users\Steve\xibo-docker\xibo-docker-1.8.11. The shared folder is there so I assume all that installed correctly.
I downloaded and installed the player for windows and I get the options screen that asks for the CMS address, KEY, and local library. The local library and key have a default value and I left them as is.

I can not figure out what to put as the CMS address. I looked up my ip using docker-machine ip. Which gives me the router IP but I also tried using my ipv4 address.
I tried multiple things and I get saving with CMS please wait and a number of errors depending on what I put in there

Everything is saved onto the same computer so I am not sure why I would use an ip address or maybe I skipped a networking step but I am basically confused at this point. Can anyone help?
Thank you

Thank you for the background information about your CMS setup.

You mentioned you are using Windows 10 but not a Pro version, so I expect you have followed the instructions for the Docker Toolbox installation.

If you are not sure whether you have missed any steps, I would recommend checking the Installation instructions just in case. I would definitely make sure that the Port Forwarding and Firewall configuration have been set up correctly:

The IP address you need to enter into the Xibo Player Options is the IP of the machine that is running Docker Toolbox.

Many Thanks.

I went through the instructions again and opened the VM and added the http, and XMR settings. I opened the docker tool box and ran docker-machine ip. I got an ip back of I have the VM open with the window that says default[running] oracle vm virtualbox. I also have the docker tool box open.

At this point I opened the player options and put a CMS address in of because my CMS is installed at C:\Users\Steve\xibo-docker\xibo-docker-1.8.11

Should I be doing something else? I think I am having an issue understanding how the docker, vm, and player all work together. These are my assumptions.

  1. The docker tool was only used to install the CMS
  2. the files at C:\Users\Steve\xibo-docker\xibo-docker-1.8.11 is the actual CMS and the player uses those files
  3. The player somehow gets to the files at C:\Users\Steve\xibo-docker\xibo-docker-1.8.11 and runs the program.

This is the current error I get in the player using the following as the CMS address

Client found response content type of ‘text/html; charset=UTF-8’, but expected ‘text/xml’.
The request failed with the error message:

Fatal Error - sorry this shouldn’t happen. SQLSTATE[HY000] [2002] Operation timed out

Any idea what I’m doing wrong? do I do anything with the VM? I only put the http, and XMR settings in and have it open and running. Do I run something from there?

Also in the docker toolbox if I run the “ls” command what should I see? This is what I see
boot2docker.iso docker-compose.exe* docker-quickstart-terminal.ico kitematic/ unins000.dat
docker.exe* docker-machine.exe* installers/* unins000.exe*

Does this mean I am running the xibo cms?

I go this after running docker-compose up - d Does this mean I am running? What do I do next?

$ ls
cms_custom-ports.yml.template config.env docker-compose.yml
cms_remote-mysql.yml config.env.template-remote-mysql LICENSE shared/

If your CMS is on the Local machine with the IP address, the CMS you need to enter is:

You do not need to add/xibo-docker-1.8.11 to the URL. Can you confirm if you are receiving any errors after correcting the CMS address to the above?

Many Thanks.

I assume you mean using the xibo player options CMS address.

When I put in the CMS address.

sometimes I get error unable to start CMS and now I get
Client found response content type of ‘text/html; charset=UTF-8’, but expected ‘text/xml’.
The request failed with an empty response.

I would recommend taking another look at the Installation manual and making sure you have followed all of the steps correctly.

You mentioned in your previous messages that you have installed your CMS at the location:


As it states in the Docker Toolbox Manual:

Using the default settings, you must extract/install the Xibo CMS inside the C:\Users directory for correct operation. Using an alternative location will cause your uploaded content and layouts to be lost.

Can you also confirm that you are able to log into the CMS itself? I cannot see in your previous messages that you have logged into the CMS.

Many Thanks.

check the config file…make sure there are no port conflicts