New error - Retrieve Remote Resource

Yesterday I updated the CMS, but the library folder was moved. So I moved it back, and all worked.

Today, some RSS News are shown correctly and updated, but others have this error:

RetrieveRemoteResource. Message: Unable to Get 13_134818624…html

Again, the error is only about images. The RSS text is shown normally.

I didn’t find any other file like this on server… Is there a way to clear the cache of those RSS, to download all files again? Or could this should not solve the problem…?

You can try it, yes, you will be looking for files like:
ticker_1adbc8ef45572a85586a876124f4aa4a that’s basically media rss (images) from ticker.

You can also make sure that links to the images are correct (in the rss feed) - just copy/paste links in to the browser.
It is possible that you have some big images (like from nasa feed) that were not fully downloaded (time outs) so you can try to download them again.
You can also make sure that your php settings are correct - php.ini settings

Well… My office’s energy crashes, so the player restarted and the feeds came back to work again, strange. The solution was to restart it. xD

But what exactly are those 13_214525…html ? I couldn’t find them anywhere.

The RSS has updated, and the same error occurred. And I can’t restart the client every time this happens.

Those are the player cache of the code required to present the ticker correctly (basically some HTML the CMS sends to the Players).

If you have images in your Ticker (MediaRSS) then the CMS will have downloaded those images and cached them in the library - depending on your ticker updateInterval these images will be refreshed or replaced with new ones if the feed changes.

It sounds like the images in your ticker as taking a long time to download and therefore not being provided to the Player in time.

How long is your Ticker on screen in total? You will probably find that the images appear after the second rotation?

It’s about 17sec the region of the image. The layout has abou 20secs.

When it updates the feed, the images are shown only on the second rotation indeed. But in some layouts, they doesn’t show at all, and this error message appear on log.

It may be necessary to enable logging in the CMS and on a problem display to diagnose further.

RetrieveRemoteResource. Message: Unable to Get 13_134818624........html is not directly related to the images, it is actually the entire feed - meaning the players without any images are playing from local cache (and perhaps the images are no longer in the required files and have been deleted locally).

Well… Everything is working fine now. Maybe it was something with Old cash and the new version of CMS.

Well, good to hear that :smile: