Multiple Players on Same Computer

Hello All,

New to Xibo and attempting to setup a video wall with 1x3 4k TVs. I have seen several forum posts about running multiple clients on the same machine, but I have not been successful in getting this to work.

I have seen that the Xibo player directory needs to be copied, that the display ID must be unique and that the cache location for each player must be unique. I see both displays in the CMS and can run them individually, but have not been able to get both players to run at the same time. I have setup a simple layout that is unique to each player and set those layouts as the default to verify that each player is able to execute individually. However, upon launching the second concurrent player nothing happens.

Is it still possible to run multiple players on the same computer in Xibo 1.8.3 under Windows 10?


Brian Scheller

Do you have separate display profile assigned to your second player?
you will need to create one and on the location tab specify the player size and offset - as otherwise both players will be on the same monitor.

You will most likely also want to make a change in the watchdog folder of your new (copied) player as well - so it knows it has to rather the second player .exe.

Perhaps have a look here for a bit more detailed instructions the manual will be updated with those in the next release.

Hello Peter,

Thanks for the quick reply. I was missing the profile portion. I did setup a new profile but still not able to get the second monitor working. I did have to set the scaling to 100% from 150% in order to get the positioning to work correctly.

If I launch only the second Xibo client, it works as expected. If I launch the first Xibo Client and then start the second Xibo client, there is an IE browser that appears on the second monitor and states that the web page cannot be found. The IE window is full screen, so I am not able to see the URL that is being accessed.

Any other suggestions?


Brian Scheller

It could be the local embedded webserver - we’ve recently added that to the instructions in my previous post.

Could you try changing the embedded web server port in the display profile assigned to your second display to 9697 and see if that will help?

When you start just the second player, I assume it does appear on the screen that you want? ie the player size and offset is not correctly set in the display profile assigned to that second player?

Hello Peter,

Thanks again for the quick reply. I had just noticed the other thread where you had mentioned the embedded webserver port. The first attempt produced a cannot access page error. I checked the config.xml from the library for the second client and ensured that the port was updated and tried again and it work successfully the second attempt.

The second client is displayed in the correct position. It was not initially but after adjusting the scaling to be 100% did position where expected.

Thanks for the help.

Brian Scheller


I just followed the instructions to create a second instance of a player on the same pc (xiboclient2.exe) , so far so good.
Next, started the xiboclient2.exe with “o” in the startup arguments and dedicated another library than the first player.

Navigate inside the Watchdog sub folder, edit the app.config file, set the ClientLibrary to be the library folder you’ve configure above and set the ProcessPath to be the path to the renamed XiboClient2.exe.
What do you exactly mean by "set the ClientLibrary to be the library folder you’ve configure above"
I see the xml file but where do i complete this?

Thanks in advance if someone could help me.

If you open that XiboClientWatchdog.exe.config

you will find the following in there:

    <setting name="ProcessPath" serializeAs="String">
        <value>C:\Program Files (x86)\Xibo Player\XiboClient.exe</value>

As it is copied from the default player installation, so you will need to edit that link to point it to your second player executable instead then save the config.

There is a line about clientlibrary in that config as well, you can configure it there too - although I think that should be populated correctly when you start the second player.

Thanks for the quick reply,

The processPath is adjusted to the second player.
When i launch the second player from the options screen, i see the second player coming up and disappear.
Altough the first player keeps playing on the first screen.
In the system tray, i get the following message:

Hi Peter,
You previously posted a link ( to a setup guide for the windows client but that doesn’t seem to exist any more. Do you have a new link for that documentation?

Nevermind, I found the new link: