Migrate 1.7.9 to 1.8.0

Hello all!!

I tried upgrading today from 1.7.9 to 1.8.0. I copied the
settings.php to the new folder and then Login.
I download 1.8CMS ( no docker because i use windows2012R2 )
Step 1 to 63 worked fine
and then the following Message in Step 64 in the Upgrading Screen

SQLSTATE[42000]: Syntax error or access violation: 
1055 Expression #1 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'xibo.lkmediadisplaygroup.id' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by

I click “Skip this step”

Step 64 to 89 worked fine

But in Step 90 : message appears

Erreur inattendue, veuillez contacter l’assistance.

You know any solutions for that!! Thanks a lot


In the short term, you’ll need to roll back to 1.7.9.

Skipping steps in the upgrade procedure is a really bad idea unless you’re 100% sure you know that it is safe to do so.

Once we have someone available who might be able to understand the cause of the upgrade issue you have, then they will respond and you can try the upgrade again.

Step 64, I changed this :

      "step": "De-dupe any Media/Display Group Assignments",
      "action": "CREATE TABLE `temp_lkmediadisplaygroup` AS SELECT `id`,`mediaid`,`displaygroupid` FROM `lkmediadisplaygroup` WHERE 1 GROUP BY `id`,`mediaid` ,`displaygroupid`; DROP TABLE `lkmediadisplaygroup`; RENAME TABLE `temp_lkmediadisplaygroup` TO `lkmediadisplaygroup`;"

But in step 90, “Unexpected error, please contact support”

I’ve created a bug report for the de-dupe step: https://github.com/xibosignage/xibo/issues/1118 - your fix wasn’t quite right, although I don’t think it would make any difference.

What is the title of step 90?

The Title of step 90 is “Add XMR Columns to display Table”

same problems Error During Upgrade to 1.8

Does that still happen if you roll back the database back to 1.7.9 (from the backup you took) and then upgrade again?

As you can see from the topic you linked to I am quite confused why this is happening. If you have DB access can you check the contents of the version table at the point you get stuck on step 90?

The best option would be to provide, if you are able, a link to your DB export before upgrade, we can then restore that in a test instance and run through the same steps here. You can PM me the link to keep that content private if required?