Manual Installation on 2.0


#1

Installation problems


2.0.0-rc1 install problemm
#2

Yesterday dowloaded manual intall package for 2.0, tried , but unfortunately got error ,

Write permissions are required for web/settings.php and cache/ , everything seems same with 1.8.2 permissions, could not find any solution to go next step .


#3

Just replace some text inside views->install-step1.twig

{% if config.EnvironmentFault() %}
<form action="{{ urlFor(“install”, {step: 1}) }}" class=“form-inline”>
{% set title %}{% trans “Retest” %}{% endset %}
{{ forms.button(title, “submit”) }}

{% elseif config.EnvironmentWarning() %}
<form action="{{ urlFor(“install”, {step: 2}) }}" class=“form-inline”>
{% set title %}{% trans “Retest” %}{% endset %}
{% set link = urlFor(“install”, {step: 1}) %}
{{ forms.button(title, “link”, link) }}

{% set title %}{% trans “Next” %}{% endset %}
{{ forms.button(title, “submit”, link) }}

{% else %}
<form action="{{ urlFor(“install”, {step: 2}) }}" class=“form-inline”>
{% set title %}{% trans “Next” %}{% endset %}
{{ forms.button(title, “submit”) }}

{% endif %}

to

<form action="{{ urlFor("install", {step: 2}) }}" class="form-inline">
{% set title %}{% trans "Next" %}{% endset %}
{{ forms.button(title, "submit") }}
</form>

it will skip the error

you will also probably have an error with exeptions field
so you will have to disable strict database in mysql

just replace sql mode to
sql-mode=“NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION”

inside my.ini of mysql


#4

thanks sir , solved a charm


#5

Thanks - we will take a look at the original problem and work on a fix:


#6

We’ve been trying to diagnose this issue today and cannot find anything wrong with the manual installation route.

Making those changes to the Twig file as you have done will just hide the environment error you were experiencing (we do check those things for a reason). You will most likely have further problems in the future.

Would one of you be willing to send us the results of a report fault wizard so that we can see which environment check failed and advise you accordingly.

Thanks!


#7

How you can send the report fault wizard if you cannot install the Xibo?
Write permissions are required for web/settings.php and cache/ is the problem, even if the write permissions are given, the problem occur on IIS.


#8

hi dan thanks a lot for spending time about my problem, but for settings error , i do not think twig file changes coused this setting 500 problem , i just made 5 twig edit and 3 css, i kept all files , and i got back to fresh installation back by changing files with original but unfortunately same ,could not make settings page work…, i can send wizard log report …,if helps you


#9

You said you had a workaround for install?

Thank you for this information - that is useful. I think it may be a problem because it is trying to check

is_writable(PROJECT_ROOT . "/web/settings.php")

but that file does not actually exist yet on manual install.

I have changed the logic in there slightly