"Lost" the content when server rebooted


As the topic said i “lost” the content with a server reboot. I know that this is a known bug.

This is what i have tried to do.

1.Restart the CMS container (docker.compose stop/start) - Still same issue
2. Restart and check the settings in the docker. (Shared C) - Still same issue
3. Unchecked shared C in docker (And cheked it again) - Still same issue
4. “restet credentials” in docker - Still same issue
5. Now i probably did a bad thing :slight_smile: I tried to run “docker-compose up”
After this i got a new problem:

C:\Xibo>docker-compose start
Starting cms-db … done
Starting cms-xmr … done
Starting cms-web … error

ERROR: for cms-web Cannot start service cms-web: driver failed programming external connectivity on endpoint xibo_cms-web_1 (06a1a8cde3d5808654ee0556563669e8dcc6527a8f6f9c53f0e1052e6881d54a): Error starting userland proxy: Bind for unexpected error Permission denied


Xibo version: 1.8.10

Your Xibo Docker installation, by default, stores your data locally on your machine, in a sub folder named ‘shared’. This is then mapped into the Docker containers as a ‘volume’. The file path of these volumes is stored within the ‘docker-compose.yml’ file and can be viewed by opening it with a text editor, such as Notepad. Before making any further modifications to your setup, I would first confirm that the ‘shared’ folder is still there and contains the cms/library folder within it. If the folder is indeed there, please create a backup before making any further changes to your Xibo Docker setup. If you have changed the default locations of the volumes in your ‘docker-compose.yml’ file, then you should confirm that they are indeed in the folder you have created.

Unfortunately, the Docker process running on your system can lose permission to access the shared folder, causing the volumes to fail to mount. If this should happen, your data will appear to be lost within the Xibo CMS. Resharing the C: drive was indeed the right thing to do, but only if your shared folder (or manually configured library folder) is indeed available. This is why it is important to locate that folder first.

Regarding the error you are receiving when starting docker, I have included a link below to a post that may help to resolve the issue:

Many Thanks.

Hi, and thanks!

The shared folder is there, and i have a lot of backups (I do a backup every night).

The second issue i still working on with the link you sent me, but netcfg -d didn’t fix the problem.


I’m glad to hear you are making regular backups of the library, this should help to ensure your data is not indeed lost.

Can you confirm that there are no other services using/listening on port 80? If you have another service using port 80, you will need to change the port Xibo is using. This can be done by opening the ‘docker-compose.yml’ in a text editor and changing the port numbers under the ‘ports’ parameter.

Can you also confirm that you are running an elevated Powershell as Administrator when running these commands?

Many Thanks.

I use the port 8080 and nothing else should use that port.
I use the powershell as a administrator.

Thanks, again!

The error message you pasted into your original post, suggests that port 80 is being used.

When you run the ‘docker-compose up’ command in Powershell, it will use the ‘docker-compose.yml’ file, which has port 80 set as default. Can you confirm if you have configured this file to use port 8080?

If you are using another file to set the port used, you will need to run the command ‘docker-compose up -f’, using the -f flag to state where the configuration file you have created is.

I have included below a link to our documentation explaining how to use a different port, as well as how to use an alternative file to configure using a different port:


The relevant information is under the Using Different Ports section.

Many Thanks

I have deleted 2 of my replys because they no longer matter.

Some how i missed to make the “docker-compose up” with the right syntax.

Now i have done like i did when i installd xibo the first time.

docker-compose -f cms_custom-ports.yml up -d

Now is the ports correct and i have now only one problem. I still doesn’t have the content.

What have i missed?

Now i have found the real problem, probably.


It´s empty, no files only one folder named temp. Is it possible that all the files etc just was “saved” temporarily and when the computer restarted all is gone? (No problem, i have also backups to the raw content)

If it is true, is that the same with the users and settings?

My next step was to try and upload a image and see if i can find the file in the folder library. Now i do. But when i check all the backups the images/movies are not there.

I’m pleased to hear that the compose issue is resolved.

I am sorry to hear that the cms/library folder is empty. If the data is not located in this folder, the data may be lost.

Your data should not be deleted upon restarting your machine. The volumes mapped in the docker-compose.yml file (or in your case, the ‘cms_custom-ports.yml’ file, as you are calling this file instead when starting Docker), are used to ensure your data is retained on your local machine.

It is very unusual that this folder only contains the ‘temp’ folder, as this is where the default layouts, fonts and Javascript files for Xibo are stored.

I would recommend checking the following:

  • Open your ‘cms_custom-ports.yml’ file in a text editor and check the volumes parameters. Confirm that Docker is indeed using the ./shared/cms/library location. If you have changed the ‘volumes’ paths, look in these directories to see if you can locate your data.

  • Check your backups to confirm that the .xlf, .js, and other media files are present. The .xlf files contain the description of your created layouts.

  • Check your backups to confirm that the .xlf, .js, and other media files are present. The .xlf files contain the description of your created layouts.

  • Right click the Xibo folder and select Properties. Select the Security tab and make sure the correct users have the appropriate permissions. If the Windows User Account you are using does not have permission to ‘write’, this could affect the data being stored.

Can you also confirm if this is the first time you have restarted the computer since installing and running Xibo? If you have restarted the machine before and not experienced this issue, have you made any changes to Xibo or your machine since the last restart?

Many Thanks.

The only thing that i changed in “cms_custom_ports_yml” is the port, nothing else.
None of the backups has stuff in the “library”, except the temp folder.

I did check the permissions yesterday, and they are correct. I don´t think that i has done a reboot the last month.

Now i have done everything once again (layouts, settings etc) and now it seems to work. I have a lots of files in the “library” folder and everything seems to work!

I think the problem was that the “docker” didn´t mount the “folder” correct.

I really appreciate all the help I got. THANKS AGAIN!

Thank you for answering my questions, I’m sorry to hear that the previous data is lost.

I’m glad to hear the content is now appearing in the library folder, hopefully it hasn’t been too much of an inconvenience to recreate your layouts. I would strongly suggest checking your regular backups, just to be certain that the data is indeed being backed up.

Should the issue arise again, please let me know.

Many Thanks.

1 Like