Loss of full-screen on the Xibo Clients

Hi everybody,

I’m using Xibo 1.7.5 on the Client and on the CMS. I have Windows 7 Embedded on the client xibo
(HP thin client which spread on TV). I’m using Microsoft Office 2010 (not the viewer). I diffuse mostly in full-screen video layouts (one region in the layout) and I have no error message on the cms and on the client xibo.

I have a problem, sometimes and without reason the xibo client loses full screen and is
displayed on a quarter of the screen (depending on the screen).

(The background is black on this screenshot because I use a VNC application, otherwise the client’s default wallpaper.)

However, I find this behavior when I switch off then I turn on the TV which broadcasts with

Could you help me to fix this please?

Thanks by advance.

PS: Sorry for my English bad.

Seems a bit odd.

Do you have any player dimensions specified in display profile?

It would be best to try and install 1.7.8 client and CMS, then check if the issue will persist.

No, I have only one dimension, because I diffuse powerpoint (or videos) and it goes fullscreen on all screens. I haven’t had to remove other screens dimensions?

Currently xibo broadcast on several televisions of different dimensions.

I actually think to migrate to version 1.7.8

Thank you

It’s generally where you power off the TV. Windows resizes the desktop down to it’s default resolution shrinking the Xibo player with it.

You’ll need to fix the Player size to your screen resolution in the Display Settings profile you’ve assigned to the Player.

I’ve fixed the Player size to the screen resolution in the Display Settings profile I’ve assigned to the Player.

Unfortunately it hasn’t changed, I still have the problem.

Section Displays > Display Settings > Add Profile (for each client) -> Edit Profile > Tab "Location" > Change Width and Height.

Section Displays > Displays > Edit (for each client) > Tab "Advanced" > Select "Settings Profile"

Is that correct?

I also changed the default resolution in the default profile “Windows” corresponding to the resolution of my TV screen test. (It’s my default profile for displays.)

By cons, could you tell me the location of the setting for the default resolution of the Xibo Player please? (The default resolution which shrinking the Xibo Player).
I did not find it.


The resolution it shrinks to is whatever the Windows Desktop resizes to when no monitor is attached. It’s not a default within Xibo, it’s Windows forcing the screen resolution down.

What you have done sounds correct. The Players will need to register with the display once to pickup those settings, then the Player restarted to put them in to effect.

Assuming the Displays all use the same resolution then there’s no need to have a profile per display - you can just use one for each differing screen resolution. If they’re all the same, then you can just adjust the default and set the Players to use the default profile instead.

Same here. It always worked, and suddenly Powerpoint is reduced to a quarter of the screen. Looks like a Windows Update killed some settings. Registry entries appear to have changed. It is not a simple monitor issue, since all other content is displayed full screen. Only Powerpoint layouts changed.

Hi, I’m having the same problem.
Everything was working fine, and now one of our displays is only showing a quarter of the screen.
We are running:
Windows 10 Ent 32bit
Xibo Digital Signage - www.xibo.org.uk. Version 1.7.4

Suspect this is due to a windows update, but not sure.
Please help.
Any suggestions would be greatly appreciated.


1 Like

After LOADS of messing about with the resolution and display size setting ( Change size of text apps and other items )
We finally have if working again.

I changed the resolution from 1080p right down to 1024x768, and then back to 1080p again.
Didn’t look like it was going to work, but after a reboot, it just started working properly in full screen again.

Hope this helps someone. Not a proper “fix”, but as I say, it is working correctly again…

I solved it. Did a Rollback to a previous version, and everything is full screen again. Windows had 5 updates on 4 and 5 october, but I did not want to find out which one caused the problems. I disabled Windows updates, so hopefully it does not happen again.

Yes this is a windows update thing. You will probably notice other apps and programs loading screens that look really small. This seems to occur on Windows 10 when resolution is 1080p or Higher. I first noticed it with Office 2010 and AVG.

Explanation of the problem can be found here.

Can anyone with this problem confirm if fixing the display scaling at 100% rather than the default 125% resolves it?

I can confirm this after investigation with another user (who noticed it in screenshots).

Explicitly setting the resolution in the Display Settings profile works, so the issue is due to the way the player requests the primary monitor size.

Dev references 1, 2

I had the same issue and the problem looked to be because I used a dual monitor with different resolutions.

In my case I had Monitor 1 as my main Display with resolution of 1600x900 and a Monitor 2 with resolution of 1920x1080. When I launched the Client in Monitor 2 it went full screen but the active area was in the resolution of my Main Display. I solved it by setting the Monitor 2 as my Main Display.

I was using the CMS Client v1.7.5

Hello Alex,
Having same issue, tried change the registry. It works for resolution does not change anymore. My resolution is 1280x720, when I turned off monitor, the resolution became 1024x768. After changing the registy, as you told, It always 1280x720 even turned on/off monitor. But xibo still understands tv off, it restarts the layout. After turn off tv, xibo restarts the layout again but changing the video size which not fits the screen.
I also tried to reduce resolution while xibo player working, after changing to 1024x768 xibo player restart the layout and fits the video to screen, but changing back 1280x720 again, xibo player restarts the layout but cannot fit the video, video still looks 1024x768. You can see some of desktop backgroud.
Here is ScreenShot:

So I still dont have a solution.