LInux Mint player options

Hi there,

Have just installed the player on Linux Mint, but when I try to save the options, I get the error;

Error while parsing response. Details; No such node (collectinterval)

I’m a windows man unfortunately, this may be a simple Linux issue but I have no idea where to start!
Hoping someone can help.


Welcome to the community GregB!

Can you confirm what version of CMS you are using with your Linux Player? Also if you log into your CMS and click the Display Settings option, is there an entry named Linux? If there is, please click the button at the end of the entry named Linux and choose Edit. On the General tab you should see a field named Collect Interval, can you confirm what it is set to?

Many Thanks.

Hi Daniel,

I’m still using 1.8.9. Have not had a chance to update the CMS yet. And in Display Settings, I do not have a profile for ‘Linux’


Thank you for confirming the version of your CMS, I suspect this is the reason you are encountering this error.

When you set up a Player, it will refer to the appropriate Profile in the Display Settings option to receive its configuration for many elements, including the collect interval, which is how often the Player will “check in” with your CMS to see if there have been any changes to it’s schedule etc. If you do not have a Linux Profile, the Player will not have a Profile to refer to to receive those settings.

I would recommend upgrading your CMS to version 1.8.13 or newer, as this will definitely include a Linux profile. If the issue persists after doing this, please reinstall the Player and try again. If even after the reinstall it persists, please let me know.

Many Thanks.

Hi there,

I have updated the CMS to most recent and have also uninstalled and reinstalled the Player.

Within the options menu it now connects nicely but I’m now having the issue that nothing is displaying.

In the CMS Displays -> Displays, ‘Status’, ‘Authorised’ and ‘Logged in’ are all ticked.

The Layout I’m using is very simple, no background image. One 100% x 100% region with a PNG within it.

In Design -> Layouts the layout has a tick under valid.

If you press ‘I’ on the player, the layout is listed as been invalid.

As I mentioned on a previous post, I’m new to Linux so am unsure if it may be a permissions thing.

I’m able to see files downloaded into the local library.


Thank you for your message, glad to hear you can now connect your Xibo for Linux Player to your upgraded CMS.

It’s hard to say what could be causing the issue with your Layout, can you confirm what version of CMS you upgraded to? If you are now using a Version 2 CMS, can you confirm that on the Layouts option in your CMS that you have a Status of Published for that Layout?

Can you also provide a screenshot of the layout invalid message you are seeing? If you are able to provide an exported copy of the Layout, I would be happy to take a closer look and test it on my own Player. If you decide to do that but wish to keep your Layout private, please send it to me in a Private message.

Many Thanks.


I’m using CMS version 2.1.0.
The status of the layout is Published .
Also, attached is a screenshot of the invalid message.
You will have to excuse my ignorance though, I’m unsure how to give the export file of the layout.