Linux display is not capable of playing mp4 webm video (but win can)

After several days of studying the site, I write about my problem.
I installed the server without issue on ubuntu-20.04.1-desktop-amd64
Displays were also installed, one xibo player on ubuntu-20.04.1-desktop-amd64 and the second on win 7x64 (with the client xibo-client-v2-R202-win32-x86).
Also, as a test, linuxmint-20-cinnamon-64bit with a package of codecs and vcl was installed on the third display.

Everything would be fine, but the video, previously converted to webm and mp4 (I tried it in different ways by reading the solutions to the problems on the site) using HandBrake and WinFF reproduced only the display on win 7x64.

The problem is that:
On ubuntu-20.04.1-desktop-amd64 with a pack of codecs and vcl (and mpc just in case), no video is displayed, a black screen, or a black screen with hieroglyphs in the center of the screen.
On linuxmint-20-cinnamon-64bit with a package of codecs and vcl, the video did not start, giving out at first the player error 12, then indicating that it could not load resources (404 error)

Question: on which version of Linux (no matter the manufacturer) I can run video on the display through the server without problems and difficulties, just as I can now on the display with win 7x64.

Thank you for your message and sorry to hear about your issue. Can you provide a copy of the video file in a private message so I can test on my own setup?

Many Thanks.

please check your personal messages, I sent you a link to a file hosting service

Thanks for sending me the video. I’ve created a layout with your M4V file and it is playing without issue in my Xibo for Linux player running on Ubuntu 18.04.5. Below is a screenshot showing the video playing and the status page so you can see that I’m running the latest version of the linux player:

I have not tried ubuntu 20.04 with the video yet but will again update this post once I have. In the meantime I would recommend making sure that your Linux installation is up to date and you are using the latest version of Xibo for Linux, which is 1.8 R6.

Many Thanks.

I have installed on Oracle VM VirtualBox distribution ubuntu-18.04.5-desktop-amd64 with all additional options (maximum version)
then entered the command
snap install xibo-player --channel = stable
thus installed the 1.8-R5 version of the player.
But, unfortunately, having connected the display to the server, I found the same black screen with hieroglyphs. By pressing al + f4, I saw different errors (attached). Please help!


Thank you for installing Ubuntu 18.04.5, this should help us to narrow down what is causing this issue.
For reference I am also using Virtualbox for my Ubuntu machine:

Please can you try the following:

  • Uninstall the Xibo player from with the snap remove xibo-player command.
  • Run sudo apt-get update to make sure you have all the latest updates for Ubuntu.
  • Run snap install xibo-player --channel=candidate
  • Configure your player as before. I’m not sure where you set your library location to but for reference I used the Documents directory.
  • Run snap refresh to make sure it’s up to date.

Once you have followed the above steps, can you try importing and scheduling the exported layout I have provided you in a private message. For reference, I’m using CMS 2.3.8.

Many Thanks.

1 Like

Amazing! Everything worked out! I almost lost hope.
Man, you helped me out a lot, thank you. If you are passing through Sochi, write. I’ve got beer.

Excellent news! Glad you’re up and running now, hopefully you won’t run into any further issues with the player.

Haha I’ll be sure to get in touch if I find myself in Sochi, in the meantime enjoy the beer on my behalf!

Many Thanks.

1 Like
The Xibo Community site uses cookies. What are cookies?