Linux Client cannot connect to server

I have a linux client that I cannot get to connect to a newly installed Xibo server. The client is using 1.8R4 and I have followed the instructions on the linux installation guide. The error I am getting is a “500 internal service error” - another older post mentioned checking the php.ini for a particular line - where is this stored? And is it on the client or server that I need to check?

The reason I am attempting to get Linux working is because the IE view on the windows client does not display web-clip properly, and I am hoping linux will fare better with it. I do not get any errors in the Xibo Server logs - where are the logs stored on the client?

Thanks in advance

what version of PHP are you on?

the php.ini file is usually stored in /etc/php.ini on linux

you can also check your apache logs in /var/log/httpd on linux

Thanks for replying - according to the troubleshooter I am using PHP version 7.2.24 (you’ll have to excuse me if I ask some obvious questions - I’m a windows boy really, so this linux stuff is a bit like a foreign language to me!)

I installed the server on linux using Docker as recommended in the install guide - am I right in thinking that I’ll have to open a shell in docker to get to the php file, and that’s why I couldn’t find it using locate?

I had a similar issue with a Xibo client on a fresh Ubuntu 18.04.3, the server and it’s local client worked fine. But the seperate client gave me a 500 error code back when trying to connect to the server on the local network (I could even acces the CMS), after some digging around, I just de-installed and re-installed and it worked without a hitch.

I tried that - I even tried reinstalling the OS and using the edge version instead of the stable, as I noticed that had a newer date on it than the stable release, despite having the same version number - but no dice. For now I’ve given it up as a bad lot and am redesigning the presentation to work better with the Windows client until I have more time to figure it out. Thanks for your help though :slight_smile:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.