LG WebOS device not available for a schedule layout

Hi ,
I’ve been using using Xibo CMS for a lot of Windows clients.
Now I have a brand new LG tv with webos, on which the default layout is working great as well.

But it seems I have an issue, or I’m missing something.
I would like to be able to schedule some specific layouts to that TV, as I did for my Windows clients. But this TV (using the LG WewOS profile) is not available on the list of device, when trying to schedule some layout. It is just not listed.
Is it normal ?

I’ve found a workaround by playing with options : I’ve created a group of Display, where I put this LG TV, and like this I’m able to schedule anything to that group, which finally if scheduled on the LG TV.

Well if you can tell me if there is an option I 'm missing, would appreciate.
Thanks.
Nicolas

Thank you for your message and welcome to the Xibo community!

This is a very unusual issue you are experiencing, please provide the following:

  • What is the CMS version you are using?
  • Can you provide a screenshot of the Displays menu page in your CMS, showing the entry for your webOS player?
  • Please also provide a screenshot showing that the player is not available in the schedule menu.

Many Thanks.

Hi Daniel,

Thank you for your reply.
Here are the information :

CMS docker version 2.3.7

Here is the display page :

The LG TV with the issue is : TV - expedition

And if I tried to schedule something :

I can only see my group , where I’ve added my TV as only member.

And even if I add an event :

Thank you.
Best Regards,
Nicolas

Cordialement / Best Regards,

Nicolas BRIAND | Regional IT Manager Europe
Precision | ( Office: +33(0) 1 69 73 7245 | ( Mobile: +33(0) 6 84 22 2279 | Ê Fax: +33(0) 1 69 25 7347 | Skype: vpfnbriand

Valve Precision France
ZAC de la Noue Rousseau | 12, avenue Condorcet | 91240 Saint Michel-sur-Orge

This message and any attachments (the “message”) is intended solely for the addressees and is confidential. If you receive this message in error, please delete it and immediately notify the sender. Any use not in accord with its purpose, any dissemination or disclosure, either whole or partial, is prohibited except formal approval. The internet cannot guarantee the integrity of this message. Precision (and its subsidiaries) shall (will) not therefore be liable for the message if modified. We use updated antivirus protection software. We do not accept any responsibility for damages caused anyhow by viruses transmitted via email.

Thank you for the additional information. I suspect that the model you are referring to is not supported with the Xibo for webOS player.

Can you provide the full model number of the LG screen you are using? The model number should be listed on the back of the screen, usually on a product sticker. Alternatively you may be able to find it in the system settings. The status page within the Xibo player will also state the model number at the top if the screen. You can access this page by clicking the ok/select button on your remote while the player is running and choose status from the menu that appears at the top of the screen.

Many Thanks.

The model is : LG 49SM5KE
I 've chosen that one cause it was on the xibo webos supported list.
Hope I was right.

Best Regards
Nicolas

Cordialement / Best Regards,

Nicolas BRIAND | Regional IT Manager Europe
Precision | ( Office: +33(0) 1 69 73 7245 | ( Mobile: +33(0) 6 84 22 2279 | Ê Fax: +33(0) 1 69 25 7347 | Skype: vpfnbriand

Valve Precision France
ZAC de la Noue Rousseau | 12, avenue Condorcet | 91240 Saint Michel-sur-Orge

This message and any attachments (the “message”) is intended solely for the addressees and is confidential. If you receive this message in error, please delete it and immediately notify the sender. Any use not in accord with its purpose, any dissemination or disclosure, either whole or partial, is prohibited except formal approval. The internet cannot guarantee the integrity of this message. Precision (and its subsidiaries) shall (will) not therefore be liable for the message if modified. We use updated antivirus protection software. We do not accept any responsibility for damages caused anyhow by viruses transmitted via email.

Thank you for confirming that it is in fact an SM5KE, which is indeed a supported model. This is good to know. Unfortunately I have not seen the requested screenshots of the status page from your player and the filter options on the Displays page, could you upload them in your next reply, or alternatively provide a copy in a private message, so I can a look?

Can you also confirm what user type your account is? If it is not a super admin account, can you log in using one and confirm if the same issue with the player not being available occurs?

Many Thanks.

Hi
Yes, sound like the I reply from the email, all my screenshot are gone.
I’ll try to post them from the web page instead :

And Here is the schedule issue


It only displays my group.

And yes I’m using what should have all rights to Xibo, my login is Admin, member of admin group. So I can see all our dozen of displays.

Hi, I just bought a new LG signage TV (model 22SM3G). I’ve added this screen to my Xibo CMS, and I got the same schedule issue with that one.
Is it due to the WebOs display profile for these 2 screens ? Where my other have Windows based profiles.

Thank you.

Thank you for the screenshots and further information. I wondered if it’s possible for me to take a closer look at your CMS? If you can contact me in a private message, we can talk about when would be a good time for me to take a look at your CMS and how I can access it.

Many Thanks.

This is an update on the above issue, which has now been resolved.

After further investigation it was discovered that some of the displays were associated with a user account that had been deleted. Please note that this issue has been reported to the developers for a solution in a future release. This is the issue report for reference:

If any users should find themselves in the same situation, regardless of player version, this is how to discover and potentially resolve the issue:

You will need to run the following commands against your database. If you are using a docker based setup, here is also a link to the guide on how to do that:

Command 1: select displaygroupid, isdisplayspecific, userid from displaygroup;
Command 2: select userid, username from user;

You can see in my example screenshot that running command 1 will reveal that each display is associated with a user ID. Command 2 provides a list of the usernames and the corresponding ID for that User account.

image

The issue that had occurred with NicolasVPFs CMS was that the user accounts that some of the players were associated with had been deleted. To resolve the issue the following command was run, with the A in the command replaced with a User account ID that is known to exist. B is replaced with the User account ID that is known to no longer exist.

update displaygroup set userid=A where userid=B;

Once this was completed the issue was resolved. If any users find themselves in the same situation, please be sure to backup your database and media library before running any commands in case of any mistakes or other issues.

Many Thanks.

The Xibo Community site uses cookies. What are cookies?