Layout Designer Checkout Timeout or Automated CheckIn

I am using self hosted (Docker) Xibo CMS. Since upgrading to 3.03, and more recently 3.10, I am having nothing but trouble using the layout designer. I upgraded to 3.10 last week in the hopes of resolving the issue, but was unsuccessful with just the upgrade. Note that this problem did not exist in our previous 2.x versions of CMS.

Issue:
I “Check out” my design, then start working on it. If I click “save” every 15-30 seconds, everything seems to work. But, if I spend any longer than that working on a region, the next time I click “Save”, I get an error “This Layout is not a Draft, please checkout.”.

When this happens, “Checkout” is not available as in the hamburger menu with the layout open, but “Publish Layout” is.

I am forced to abandon the changes, go back to the main layout list, then select “Design” and “Checkout” again. If I am fast enough, I can edit, then save.

Is there some sort of timeout setting in Xibo CMS3+ for checked out layouts that automatically publish or check them back in while editing? I have already disabled “Should Layouts be automatically Published?” in the main settings, but this 30-40 second getting out of sync with check-out still is happening.

Looking for any ideas…

Thanks in advance.
Jayson