Layout available for several user

Hi everyone,
When I log as a normal user, I can create a layout. Let’s call it “tutu”
The problem is, I am able to go to “autorisation” on this layout and to give some right to “Users” as “read”, “edit”…
And if I log as an other normal user, I can view the layout “tutu”.
Do you know how to avoid that?
I don’t want that a normal user will be able to create a layout for an other user…

sorry for my english :confused:
thanks everyone

In order to assign Permissions, a User would need to have access to the User page, so if you go to the Page Security for the User and make sure that the Users option (at the very bottom of the form) is unticked, they won’t have access to the page to assign Permissions to users.

Please take a look at our documentation for available Permissions.

thanks a lot for your help.
Unfortunatly, the “users option” is already unticked.
maybe my explanation are not good (sorry for my english :slight_smile: )
So : I have a normal user call “toto”. When “toto” create a layer called “creation”, there is a button call “permission”, and “toto” is able to send is layout to a other normal user call “2eme utilisateur”.

I don’t want that “toto” could sens his layout “creation” to an other normal user.
Do you think it’s possible?

thanks again for your time

When you create Users you select a User group for them to belong to, Users will then inherit the permissions for that group. If you look at the User Group page and then use the row menu for that particular group (User) is Users ticked? If you unticked here all Users that you assign to the User Group, would not have access to the User page.

You could create your own Group to ensure that you have the permissions you need for your Users.

thanks for your answer.
my issues is on the layout.
A user “toto” from the group Users (by the way, if I uncheck “toto” from the group User, I have an access denied" if I try to loged with the “toto” account.

So, when I am log with “toto”, I can create a Layout. But in the row menu of the layout, I have “permission”, and If I check “user”, all the other user can see the layout.
I don’t want that :slight_smile:

If it’s not clear enough, I don’t want to make you lose your time… thanks again

Go to your user “toto” and use the row menu to see what User Group they belong to:

You don’t want to remove the User “toto” from the group, you want to amend the Page Security for the group that “toto” belongs to:

So if they belong to the “Users” group (as shown in the above screenshot), go to the User Groups page, then click on the row menu for Users and click on Page Security:

This page shows you all the pages the “User” user group has access to:

If you scroll to the bottom of the page, untick Users and click Save:

Now your User “toto” should not have access to the Page that allows for setting Permissions for a Layout.

I already try, but it’s not working.

when I’m log as an admin, I uncheck “Users” as you said

then I log with “toto”

I still have the button “permission” on the row menu of Layout

and I’m still able to send my layout to other user of the group “Users” if I check “Users” / read or edit…

Lets try creating a new User group and giving membership to your User “toto” by following these steps:

  • User Groups>Add User Group (User A)

  • Use the Row Menu for User A and click Page Security

  • Tick the following options:

Icon Dashboard
Media Dashboard
Schedule Now
Status Dashboard

  • Save

  • Go to Users and select the row menu for “toto”

  • Click User Groups

  • Untick the existing Member group

  • Tick the new Group User A

  • Save

  • Log out as your Admin user>log in as “toto”

  • Go to a Layout and use the row menu for Permissions

You should get an Access Denied pop up

If this is not the case then could I ask as to what version CMS you are using? Please provide screenshots where possible of the above process and include what is ticked for the Page Security for your User “toto”.

I will try that today and give you an answer. Thanks again for your time! :slight_smile:

it works!!! congratulations :smiley: :smiley_cat:
I juste have a red message when I do a modification in my layout (log as “toto”)

something like “Saving user preferences failed”… But everything works correctly. Thanks again :slight_smile:

OK I found the matters. When I don’t tick “user” in User A / page security. I have the problem of “saving user preference denied”…
But if I tick user in User A / page security, “toto” is able to go to “permission” in is layout’s row menu…

I’m going to ask a person who know PHP and SQL if it’s possible to remove the button “permission” of the layout’s row menu from the database…

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.