Json error "SyntaxError: JSON.parse: unexpected non-whitespace character after JSON data at line 1 column 166 of the JSON data"

I’m new to Xibo. Trying to work through the ‘cafe guide’. If I try to add the “coffee.png”, I get the following error:

CMS-Browser: Mozilla Firefox (tried it under Linux V. 26.0 and Windows7, V. 41.0.1)
CMS is an OpenSuse-13.1 (actual Online-Update), all environment entries “passed”.

Could not find any hints in the logfiles.



It most likely is related to php.ini settings, please check that everything is as described in this FAQ topic:

Hello Peter,

thanks for your hints.
I have read the link at installation time of the CMS.
Now I have rechecked the values and raised them again.

They are now:
max_execution_time = 120
max_input_time = 60
memory_limit = 256M
post_max_size = 128M
upload_max_filesize = 256M

Also checked the LimitRequestBody in the apache-configuration. It is not set in an OpenSuSE-Installation.

Still the same error.

As you see in the screenshot, the coffee-file has only 503.96KB.


Could you please enable debugging on Report Fault page, then recreate this problem and either see what’s going on on logs page or download troubleshoot.txt from Report Fault page.

If you’d like to upload your whole log file here, please ‘censor’ any sensitive data that might be in it (or send it to me via pm)

Hello Peter,

I send you the “troubleshoot.txt” as an attachment.

There are no secret data in it, because it runs in a testbed.




for all those folks who will have the same problem:
the problem could not be solved without a reasonable effort. A friend of mine installed 1.6.3 under OpenSuSE-13.1 successfully. Unfortunately he didn’t try 1.7.4.

I reinstalled 1.7.4 on an Ubuntu 14.04LTS and uploading media now works like a charm :wink:
I don’t care about the OpenSuSE-problem at the moment, because I’m still evaluating the CMS.

once again, thanks to Peter.


Hi Poldi,

I am glad to hear that it is working for you now :smile:

Have fun with testing the CMS/players and as always feel free to ask questions if you’d have any.

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.