Issues with XMR when importing old data

Using Xibo 1.8.9 with Docker on Ubuntu 16.04 and having problems trying to get XMR to work.

Following this guide with a fresh AWS EC2 instance WITHOUT importing data I have no issues with XMR. Now if I do the same thing but bring over my library and database on install, XMR doesn’t work.

If I request screenshot, logs in cms display: Err no 43, XMR unresponsive, issue reconfigure. Reconfiguring XMR does not solve, but does show a check under “XMR registered”. If I switch the player’s cms address back to the fresh server XMR then works again.

Everything is identical on both server installs except for importing of database. I’ve looked in both databases and the XMR private address match. Imported database is from a 1.8.9 dump that was sequently upgraded since 1.7.x if that helps.

Any Idea? Thank you.

Edit: I’ve resolved the issue. I docker-compose down the fresh working server, put in my import.sql, compose up, and my data was there w/working XMR. Not sure why that worked opposed to importing data on the initial boot.

Edit2: After about an hour of XMR working fine it now again fails. Log showing err 43 & XMR unresponsive.

After you’ve imported your data, and then connected to the database manually and corrected the XMR settings, then you’ll also need to purge the CMS settings cache, otherwise your settings won’t apply.

https://xibo.org.uk/manual-tempel/en/upgrade_switch_to_docker.html

That walks you through exactly what is required. I’d down the containers you have, and start with an empty shared folder, as importing won’t do anything in most cases if you already have a database present.

Thanks Alex. I assume purging the CMS settings cache consists of clearing out cms/library/cache? Still no luck though after following that.

So I tried fresh again. Imported data (import.sql, library), ran the three database update queries (noting values did not change), deleted the contents of the cache folder/hit save button on CMS settings page. Skipped the apache proxy this time trying to rule options out, but still no XMR. Err 43 and XMR unresponsive in log.

You’re certain they aren’t pre-existing messages?

How have you configured the public address? That isn’t done automatically for you. If it’s a log coming from the player then it won’t be related to the private address as the Player never sees it.

Public address is tcp:://IP:9505

Certain they’re new messages.

You have too many colons there. It should be tcp://ip:9505

How foolish I did not notice that! Glad I copy/pasted that setting instead of typing here what I thought it was set to.

Thank you so much for your help.

1 Like

Glad we got there :slight_smile:

The Xibo Community site uses cookies. What are cookies?