Issues after mysql restore

I have Xibo 1.7.5 running on Ubuntu x64 14.04 LTS with XAMPP 5.6.14-4. I had an issue where mysql was crashing (long story, but I was able to fix it), but in the process of troubleshooting, I reinstalled XAMPP, and restored mysql from a backup. I can now get the main Xibo login screen & it accepts my user credentials, however after logging in, I receive the following message:

There has been an application error.
Can not write last accessed info.

If I attempt to click on anything in the left column, it takes me to the login page.

Any insight would be greatly appreciated.

Perhaps something with filesystem permissions?

I see that you’re using custom theme as well, could you check if the same error is displayed when you switch the theme to the default one?

You can do that in mysql

UPDATE `setting` SET `value` = 'default', userSee = 0 WHERE `setting` = 'GLOBAL_THEME_NAME' ;

Check your database for crashed tables. I suspect the user or session tables are crashed and so Xibo can’t write to your session information.

Alex, thanks for the suggestion, however I am pretty much a beginner when it comes to mysql, how would I go about doing that?

First stop MySQL, and backup what you have (backup your MySQL data and log directories).

You’d need to connect to MySQL on the command line

mysql -u username -p databasename

Change username for your database user and databasename for your database name (both can be found in settings.php) Enter the password for your database user.

Once connected, run

SHOW TABLE STATUS FROM `databasename`;

If any tables show their engine as empty or null, there’s a good chance they are crashed.

For any crashed tables, run:

REPAIR TABLE `tablename`;

I was able to run the table status command, however it looks like there were no empty or null tables (see attached).mysql table status 9-29-17.pdf (30.2 KB)

I believe that the permissions are correct on the cms web directory, however is there a default level I could reset too?

When I run the mysql command, I receive an error (see image).

I’d guess then that the user you’re connecting to the database as has the wrong permissions, or there is some other issue with MySQL that’s causing that (and potentially other) tables to be read only.