Issue with Google Slide Embed

I’ve come up with a workaround that may help some people. The issue with the box appears due to the IE11 cache. I fixed the issue by moving the cache folder and deleting the contents of the folder before Xibo starts

  1. Create a new folder (i used “iecache” and left it on the desktop)
  2. Open IE11 as admin and move the cache folder to that location (requires restart)
  3. Create a batch file that removes the directory (rmdir) and re-creates it (mkdir). This is needed as the folder has to be empty
  4. Run batch file before starting Xibo

One thing I noticed is that if the folder has to be empty if the Google Sheet reloads automatically or changes, so I wrote a scheduled task to run the batch file every 10 minutes. I’m not sure how this affects other layouts as I use this on clients that just show Slides, but it has been working like a charm. Users can update the slide on their own and it will show up in the client

Hope this helps

I created a fix!! simply add this to the Navigate event for the webBrowser and the flash object will be hidden from view:

webBrowser1.Document.DomDocument.createStyleSheet("PRESENTATION_EMBED_URL_HERE", 0).cssText = "embed{display:none!important;}"

Thank you to everyone who has had input on this issue.

Injecting a stylesheet into the document to hide any embed tags is an interesting workaround - I am sure we can do that. However we obviously need to do that only for when we are embedding a webpage with a google slides presentation as the URL.

Is there a convention for those URL’s that we could detect?

As an update regarding this issue, a bug report has been created and the Development team will look into this further. Below is a link to the Issue Report:

Many Thanks.

As far as I can tell, all my Slides presentations use the following URL prefix: https://docs.google.com/presentation

I started running into this a while back and ended up disabling flash via policy on IE and the box was no longer able to come up. Since our layouts almost all rely on this we needed to come up with a fix. I haven’t seen any side effects from this as of yet.

Can you elaborate with this fix? We are having the same problem, but when I attempted to run your fix (which I thought I did correctly) it causes the scaling of the slide show to become messed up.

For now we have reverted back to showing that grey square. Like so many others here, we are relying on Google Slides for many of our layouts due to simplicity - we use them at all our schools and school staff update slides as announcements.

Our Xibo machines are all in an AD group and we assigned the policy to them.

The exact thing we set to enabled is under:

Computer Configuration\Policies\Administrative Templates\Windows Components\Internet Explorer\Security Features\Add-on Management\ Turn off Adobe Flash in Internet Explorer and prevent applications from using Internet Explorer Technology to instantiate Flash Objects

On our layouts we have two different slideshows running, both of them are setup in google as the exact size as the box that I have setup inside of Xibo. This way I shouldn’t have to deal with any sort of scaling or sizing issues. The machines are running Windows 10 and we make sure that the screen scaling is set to 100% as well.

1 Like

@BChiarmonte Works like a charm.Thanks!

Thanks @BChiarmonte for that work around. I’m testing it now and it seems to work fine. We mostly do google slides and youtube videos (letting someone else store all our media) so this seems like a good solution for us and will finally allow me to move our players to Windows 10 as installing Windows 7 on new hardware is a sketchy trick. 10 isn’t perfect and requires some modifications, but until the linux client is out of beta and well tested I’m sticking with Windows.

This is an update regarding the grey square issue mentioned above. I wondered if anyone experiencing this issue can send me a PM with a link to their exported Layout for testing?

Many Thanks.

Just saw this now, I sent you a PM

Hi ayunami2000
I have the grey box issue and would like to try your fix but unsure where to cut n paste your code.
Could you please let me know where to place this code as I dont know much about coding.
Thank you

Hi BChiarmonte

I’m trying to use your workaround for the grey box issue but I cant seem to find on my Intel Compute Stick the following location:
“Computer Configuration\Policies\Administrative Templates\Windows Components\Internet Explorer\Security Features\Add-on Management”

Could you please tell me where i could find this so i can follow your instructions “Turn off Adobe Flash in Internet Explorer and prevent applications from using Internet Explorer Technology to instantiate Flash Objects”

Thanks

That would be found in the Group Policy Editor

Hi, maybe a late reply but the solution doesn’t work in Windows 10 Home edition. I have opened Group Policy editor but the option for disabling Adobe Flash Internet Explorer isn’t there. Google doesn’t give me an alternate solution unfortunately. Is there someone who knows the solution in Windows 10 Home? Or do I need to upgrade? Thanks

edit: Nevermind, I found a zipfile that blocks Flash in regedit and it works.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.

The Xibo Community site uses cookies. What are cookies?