IP-Adress is shown as ::1

hi
why is the ip-adress of the Display shown as ::1 ?

following this, no vnc works or wakeonlan is not possible

Where are you seeing that? It looks like IP6 protocol. Is this from a machine with the server and client installed on the same machine?

it is IP4
I see this in the Management console / Displays / column IP-Adress
yes, Server and Client are on the same machine
no matter if i use the Management console on the same machine or on a different pc within my Network

we are running a System with 4 Displays in a School, where the Server is on a separate machine, IP Looks fine.

that is a IP6 adress that is not in use try ping COMPUTERNAME -4 to get the IP 4 adress in return (asuming windows)

the IP-adress of this PC is well known, we do nothing with IP6. ping with -4 param shows the correct IP-Adress, ping without params brings IP6

when we “call” the localhost Server the first time via Xibo Player Options we have no posibility to modify wether IP4 or IP6 is transmitted

may be this is because Server and Client are on the same machine. we have another Installation with both Server and Client on the same PC and IP-Adress Shows ::1 also.

Please disable the IP6 protocol on your network adapters, and the problem should go away.

Problem is still alive
IP6 deactivated on LAN and WLAN Adapter (WLAN not in use)
Display deleted in mangement console
Player deinstall, delete all config-files, clear library, reinstall
no changes, IP is ::1

ComputerName is NUC-PC

ping NUC-PC brings :

Ping wird ausgeführt für Nuc-PC [::1] mit 32 Bytes Daten:
Antwort von ::1: Zeit<1ms
Antwort von ::1: Zeit<1ms
Antwort von ::1: Zeit<1ms
Antwort von ::1: Zeit<1ms

with -4 param:

Ping wird ausgeführt für Nuc-PC [192.168.2.247] mit 32 Bytes Daten
Antwort von 192.168.2.247: Bytes=32 Zeit<1ms TTL=128
Antwort von 192.168.2.247: Bytes=32 Zeit<1ms TTL=128
Antwort von 192.168.2.247: Bytes=32 Zeit<1ms TTL=128
Antwort von 192.168.2.247: Bytes=32 Zeit<1ms TTL=12

this is no problem at this time, but when I want to use VNC or WOL in the future, perhaps it is …

Your system is resolving NUC-PC to an IPv6 address - you can clearly see that in your testing.

Xibo will get whatever your system says it’s IP address is, and in your case, it’s saying that it’s got an IPv6 address. If you disable IPv6 on your system, it will be forced to use the IPv4 address. I appreciate you say you have done that, but clearly your test shows it isn’t disabled. Perhaps Windows requires a reboot to fully disable it? Otherwise, it makes no difference what the IP address shows if the CMS and Player are on the same machine, as the CMS can’t wake itself with WOL - you can only wake remote machines configured to do so.

ok, restart is a good idea…

I will Report the results of testing systems with separated Server / Client.

Thank you

here are the results:

uncheck IPv6 in any or all Network Interfaces does not help
restart after uncheck does not help

MIcrosoft provides a Fix for download to to the Job. I tried this and after a restart (not provided by this fix) IPv6 was disabled and the Player Registers with 127.0.0.0 (both Server and Client on localhost).

here is the link: https://support.microsoft.com/en-us/kb/929852

best regards

1 Like