Internet access issue with forecastio

I am unable to fetch forecastio weather info from the web even though the rest of the PC’s apps has internet access.

The CMS log reports:
2604 16-03-24 05:54:32 CMS Forecast\Forecast request
Unable to reach Forecast API. No Host Found (HTTP Code 0). Curl Error = Recv failure: Connection was reset

I have created the equivalent url that should be sent and pasted it in to a browser and all works.

The url is (excluding my api key):,144.844788 which is for Melbourne Australia.

My network is behind a proxy server and it uses an automatic proxy config script and is in the browser connection options pages under the “Automatic proxy URL”. If this is the issue, how do I enter this into the proxy setup page in the CMS server?
Do these same settings get propagated to the display clients or do they each need to be set up separately?

As background: I don’t need to enter any credentials or domain information to access www sites even from with in applications like a url in a excel or from the browsers (Mozilla or IE). Can I make the CMS and the clients use the same method for internet access as the rest of the pc?

I’m running a fresh install of 1.7.6

Seems like a

Please have a look here: Using Tickers, Forecast, Twitter and other external resources that make use of HTTPS connections

and make sure that everything is where it should be, all patch are correct etc.

Hi Peter,

It was a mix of certificates and proxy url but the data is coming through to the CMS server now.

Next problem… It isn’t going through to the clients.

Do I need to do something with the proxy or certificates on the clients too or is the data downloaded from Forecastio by the CMS server and then distributed? If it’s the later then it should be working.

By the way, RSS feeds on the client work ok.