Installation of XIBO on Turnkey LAMP on VM machine

Hi I am installing XIBO on a Virtual machine in Vsphere. I am using turnkey LAMP based on Debian.

All the pre requisits are ok apart from :-

File System Permissions Write access required for settings.php and install.php

I’m logged in as root.
I have searched the machine and settings.php does not exist.
install.php in the XIBO directory exists and I have set the permission to RWX on user, group and others.

I cannot fix this to continue installation.

I also have none critical errors:-
Large File Uploads You probably want to allow larger files to be uploaded than is currently available with your PHP configuration. - We suggest setting your PHP post_max_size and upload_max_size to at least
128M, and also increasing your max_execution_time to at least 120 seconds.
(I have amdened the file and restarted Apache but the error persists)


Internationalization International Support for formatting Dates, Numbers, etc.Translations will still
function without this PHP module, however dates, times and numbers will not be shown in your locale.
(notes I have foiund refer to Windows installations and i cannot get this wo work on Linux)

Any help gratefully recieved.

The installer needs to be able to create that file in the root folder - therefore the webserver user needs write access to that folder.

Regarding the other points, have you seen:

Ah Thanks Dan, setting the permissions on the Xibo directory under WWW ticked my box :wink:

The link ending PHP/684 is one I found but refers to Windows installations and the DLL is not to be found on my Linux appliance.

I have also previously completed all the steps shown in upload bigger files link and restarted the Apache but the error persists.

There is also an apt-get install command in that article to download the intl package

I can only suggest that you might not be editing the right php.ini file - it depends how the box has been setup as to where that file is. This might help: php ini - How can I know which 'php.ini' file is used? - Stack Overflow

Thanks again Dan. There was another php.ini file and i have made them both the same to be on the safe side.

It’s still doing the same thing but everything else is working fine. Just getting to grips with it we have 8 old samsung screens around the place with mebedded XP currently running a horrible samsung magicinfo system. its a challange to get IE 8 and .net 4 onto them :wink:

I can imagine!

If the fault page is reporting that large file uploads / intl support are warnings then those extensions aren’t available for php to use. I’m really not sure why if you’ve identified and adjusted the necessary lines to the php.ini file(s).