I'm trying to stream UDP video (in Windows), but it's not working

I don’t think this is officially supported on Windows, but there must be a way to get it working.

We’ve been using something else to do the screens around the school, but since the hardware broke I’ve been looking to use Xibo. I can get our UDP stream to play on the other software and also in VLC by just entering the address (e.g. udp://@ I’ve tried several ways to try to get it to play in Xibo but it does the same as when I try to play it in a browser. I generally get a blank box, a VLC traffic cone, a broken link style box, or similar.

I installed VLC on the ‘player’ PC so it would have the VLC plugin, but nothing is playing.

The Windows 10 one doesn’t play the stream in VLC (the orange bar just bounces left and right), but it shows the traffic cone in the Xibo player. The Windows 7 one plays in VLC but just gives a blank box on the Xibo screen with a small square icon in the corner.

I can stream Sky News from Youtube, but I’d much rather use our own internal server for the stream, and use BBC News.

I thought playing streamed video would be a very common thing to do with digital signage software, so I’m surprised at how difficult (or impossible) it is.

Has anyone ever managed to get a UDP stream working in Xibo for Windows? If so, how?

Any help would be greatly appreciated.

After messing with it for a few weeks (almost exclusively on Windows 10), I’ve just had another go on Windows 7 and got it working using this, in an ‘Embedded’ type box:

    <object classid="clsid:9BE31822-FDAD-461B-AD51-BE1D1C159921" 
    style= "width: 1080px; height: 720px;"
    <param name="src" value="udp://@" />

    <embed type="application/x-vlc-plugin" pluginspage="http://www.videolan.org"

So it must be a Windows 10 problem.

I found if the default program for video was set as VLC, with your embedded code it will work in Windows 10.

Thanks for the reply. I couldn’t try again until now.
I’ve just tried it. I changed the Win10 default video and audio players to VLC. Unstalled updates, and restarted. It’s just doing the same thing. I get the black player area with the VLC traffic cone in the middle. Nothing plays, even if I manage to press play on the button with the invisible mouse.

I tried to install Win7 on the ComputeStick, but it won’t recognise any USB device when booting, so I’m stuck with Win 10 that doesn’t play streamed video.