HTML Files not working properly without internet connection



We have started using HTML menu Files for Digital signage. We have faced a problem that if the device is not having internet connection the transformation from one HTML file to another doesn’t happen though the HTML Files is already downloaded in devices.

We were using Static images and videos in past for Digital signage and it was running perfectly fine even when devices was not having net connection and transformation from one video to another video or from one static image to another static image happen easily and it didn’t required any internet connection.

My devices are going to be used in offline mode only (without internet connection). Please help me out how to run HTML files.


How do you have this setup?

Xibo doesn’t provide any support for caching webpage media types, so they will stop working without network connection if you haven’t somehow arranged for all the HTML files and associated content to be stored locally on the device and served from there.

If you’re using the embedded html media type, then the HTML is cached locally on the Player, but again, you would need to get any associated files (images, javascript etc) on to and served from the Player for it to work with no network connection.

Finally Xibo only stores two days worth of schedule information on the Player by default, so if you’re having no network connection to the Players, after 2 days, it will start showing your default layout until it is able to connect to the CMS again.


Hi Alex,

Referring to your reply…

Can I upload the media and JS files from “Media” page on CMS and somehow link the embedded HTML code to the files? I couldn’t find an option to do this.

We have been pushing content to the devices 1 to 2 months in advance by changing the default settings for “Send files in advance?” from Settings to seconds equivalent to 1 or 2 months. Am I mixing two different things here.?



Yes you can upload JS files to the library as genericfile types. You would then have to manually assign those files to the Players you want to use them on. You can then refer to them in your embedded HTML by their library IDs (eg 55.js).

As I said in my reply, by default the Player caches 2 days worth. Setting to 1 or two months is pretty extreme and will cause significantly more load on your CMS server, but as long as you’re happy with that arrangement then that’s fine.


Thanks Alex. We will try this out and get back with the updates here :slight_smile:


Hi Alex,

I assigned JS and image files to the device but still see only text content without animation and images. Any idea what might be wrong? We see the same result in “Preview Layout” also (but in preview the files are not assigned).

If this works, then the quickest way to assign files to all the devices is to put them in a display group and assign files to the group. Correct?


Did you files end up in the Player library?

If so, are you sure you’re referring to them by their local names (eg 55.js) not the name you uploaded them as?

If they refer to each other internally, you’ll need to adjust their names before uploading to take account of that.


We have kept the file name same as the name with which we uploaded and code also has the same name. Still don’t see even a single image…


The name you upload it as is irrelevant.

When you upload a file, the CMS gives it a numeric name - eg 55.jpg, 66.js etc

Those are the names the files will have in the Player library, and those are the names you will need to refer to to make use of those files.


From where can I find this name? Is it the ID column in the Library page that is the name?


Yes, combined with the original file extension.



Regarding to the subject of this thread, I would like to ask about this problem:

We have a project of 21 led signs with android players with Xibo CMS.
All of them are going to reproduce html files. As I’ve read several times, this kind of files need internet connection all the time for showing the contents. We accept this. The problem is when there is a lost connection, the screen shows the url of the html, and our client asks for showing a default image in this case, or even a black screen, but not the url address, because this is quite “ugly”. Could you help me in relation to this issue?


Hi! I’ve made some changes in the layout, and I have realized that what is shows when I disconnect the player from internet is actually the next message(the message of browser):
“Web page not available
The wepage at
(address of url)
could not be loaded because:

In this case that text is black unless the line of the addres url, that is blue.
My conclusion is that we have the color background black as default, so, we can’t see the text, only the url address that is in color blue.

Is there any way to avoid to show this message?



Thank you for your message. The error messages shown by your web browser cannot be removed by Xibo. When using the Webpage Widget, you will need to ensure you have a stable network connection to avoid these errors appearing.

CMS Version 2.0.1 has a new Module named HTML Package, that allows you to upload a webpage in htz format and add it to your Layout. Once scheduled, the htz will be downloaded, allowing the Player to show the webpage from the Local Library on the Player instead of retrieving it across the internet. This does not solve the error messages you are seeing but if your internet connection is intermittent, this may be a more appropriate solution.

I have included a link to the documentation below:

Many Thanks.