How to show layout in Windows layer or Client side

how to show layout in Windows layer or Client side
please help me i am new on xibo
please some buddy tell me that how to show layout which you design on server side
how to preview that layout on Client Side
i have installed xibo-client 1.7.9

I assume you have CMS in 1.7.9 version and Xibo for Windows in 1.7.9 version, is that correct?

Is the player already connected and licensed with CMS?
If not, please see here

Then if you already have a layout designed in the CMS and player connected to the CMS, you will want to:
Navigate to Schedule Page in CMS,
Click the Add Event button,
Select your display and your layout
Specify the start and end date
Click Save button

In 1.7 series CMS, your player connected to the CMS each collection interval, this is a settings that you can adjust on Display settings page -> Edit display profile assigned to your display.
Each collection interval player will connect to the CMS and start downloading any new media files, schedule etc
Once it finishes downloading required files it should start displaying your layout.

Peter i can not understand your solution could you please elaborate it more

Perhaps let’s start with what you currently have.

Do you have a Xibo CMS installed on your webserver or not?

Peter i have fixed the issue now peter i am facing some problem in schedules
i have schedules my layout in xibo calendar but it’s showing default layout instead of schedules layout
some time it show layout according to calendar but most of the time it’s show default layout
how can i fix this error pleas tell me what should i suppose to do to fix this error

i am using Xibo 1.7.9 Version for CMS and XIBO Player

this is my schedule which i want to show on xibo player

Right and player does not show this layout?

Can I see a screenshot of status window on your player please?
You can also double check that your layout is valid - there is a layout status column on Layouts page, if it is invalid, player will not display it.

Also, what do you have in CMS Settings -> Regional please?
As those dates there does not seem right to me.

wait i am sending you
stay online please peter

here is my xibo player status

Peter this is my layout page

I’ve closed your other two topics, as they are about the very same issue and there is no need to have 3 topics open about it.

I need the following screenshots from you.

  1. CMS Settings -> Regional tab
    As clearly the date format in your CMS is all over the place.

  2. Player status window when it has the problem, meaning when your Xibo for Windows is running and displaying layouts press ‘i’ on your keyboard, that will show the status window, I need to see that window please.

  3. Layouts page, not necessarily a screenshot of it, but please double check that those layouts you schedule are valid - no empty region etc.
    CloseLayout seems to be invalid - X in Status column.

peter here is my player status it’s active

here is my regional time screenshot it’s according to my timezone

“CloseLayout seems to be invalid - X in Status column.”

Peter how to valid my CloseLayout could you please elaborate it please

Player status
Could you please click ‘Lunch Client’ and when it’s showing your layout, press ‘i’ on your keyboard
that’s the status window I want to see, not the player options.

Regional settings
Do you have ‘Show International Dates?’ enabled? If so, please disable it.
On schedule page, displays page etc it clearly shows wrong dates there, date format looks fine, so at a guess it is caused by ‘show international dates’.

I do not know why is it invalid, as I’ve not seen it, but since it has X in status column, CMS certainly thinks it is an invalid layout. Why won’t my layout play? / The splash screen plays instead of my layout

okay got it here is screenshot

Ok thank you.

In addition to fixing the regional setting (international dates) and the layout that’s invalid - you can send it to me via private message if you do not know why is it invalid.

Please also open php.ini and look for the following line:
always_populate_raw_post_data -1 and make sure it’s not commented out (no ; before that line in php.ini)

Restart your web server after you make this change.