How to permanent change the media upload file max size to 10M from defualt upload_max_filesize = 2G in XIBO 2.0.0

Hello Team,

Could you help to change the upload media file size to 10M from default 2G in XIBO 2.0.0.

Server information:

Ubuntu: 16.04
Docker: 18.03.1-ce, build 9ee9f40

Any one help me here ?

Welcome to the community!

Please do take a look at our FAQ topic here: Upload files bigger than 2mb / increase file size limit

Thank you


Thanks for an update, it is not working for as i expected.

I tried the same and save my changes as well but when i restart the container of web service of XIBO, the changes gets reverted back to its default.

I have made changes in following file.




Thank you for your message and for the information you passed on.

I am also using a Docker based install running on Ubuntu (mine is 18.04 but that should not make a difference).

It sounds like you may have edited the wrong config file if you are using a Docker based installation. When I decided to increase my max upload file size to 6GB, I did the following:

  • I used the command docker-compose down to stop the CMS service. You may find you can use docker-compose stop but I prefer to down.

  • Next I edited my config.env file for my Docker install. I’m not sure where you have saved your installation but navigate to the directory where your config.env file is and enter sudo nano config.env. You may not need the sudo part depending on how you have configured your user account.

  • Once the config.env file is open in your terminal, navigate to the bottom and you should see the PHP elements you are looking for but commented out. I removed the # in front of each entry and set the upload limit I wanted:

  • Save the changes to config.env.

  • I then start my service again with docker-compose up -d. If you used the stop command instead of down, you may instead choose docker-compose start.

  • When I checked the limit, it has now received the changes:

Can you confirm if this resolves your issue?

Many Thanks.

Hi Dan,

Yes, it is working for me.

Thanks a lot…

That’s great news, thanks for confirming it is now working. The guide has been updated to include a section on Docker installations.

I just realised that this is the first post you have created, welcome to the Community Forum!

Many Thanks.

I have made these same changes to the config.env file. Everything seems to work fine, the upload media popup show that it will accept files up to 20G but the upload fails at just over 4G. I have tried setting it to 10G and to 50G, it doesn’t seem to matter what I set it to it always fails at about 4G. Any idea where I can start troubleshooting this? Ubuntu 18.04 recently upgraded from 16.04. Docker version 19.03.5

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.