HLS Streaming on Windows Player not working


I have Xibo player 1.8.2 installed on Windows 10. I am attempting to play an HLS stream. The preview works fine in Chrome (with an HLS extension installed), and works in Edge. However, I am getting nothing in IE11 or the signage player.


If you can share the hls url with me I can try it here locally.

Perhaps also double check if the browser emulation settings are in the correct place (there is a bug regarding that in 1.8.2) - Enabling HTML5 in the Windows .net Player


The stream itself is running on the local network with no access from external IPs, so the URL would be fairly useless here.

Looking at the registry, the registry key specified in the link provided is 11000 already.

Opening the stream URL in VLC on the signage player PC does work.


Did you found a soultion for this?

In the Preview, the design (including the hls) is working. But on the Clients it’s stay black. Clients are on the latest Version and the hls stream is reachable via VLC and IE11.

HLS URL is formated like:

It’s a internal IP so not possible to reach form outside, and the clients are on the same subnet.


I found a solution by my own.

The stream providing webserver has to be modified to enable CORS (cross-origin resource sharing).
Howtos can be found here: https://enable-cors.org

In my setup, I use the xibo docker version, so I created a nginx docker with ffmpeg and modified nginx ( https://enable-cors.org/server_nginx.html). Now it works perfect with the windows clients.


Unfortunately this does not work with my setup. I’m using Wowza and CORS is enabled on all streams by default.


Could you try to open it in IE in the player local webserver please, then inspect it to see if it shows any errors ?
that is http://localhost:{PORTNUMBER}/{FILENAME}.htm

webserver port number by default is 9696
You can double check that in Display settings page -> Edit display profile assigned to this display -> Advanced tab -> Embedded Web Server Port

file name - is the .htm file name that corresponds with this layout in the player library it will be for example something like 854.htm
so then you’d navigate to localhost:9696/854.htm to open it

Xibo player must be running for the local webserver to work and obviously you’d need to check it on the PC that runs the player.


I seem to be getting video now. Nothing has changed on my streaming server, however since I started this topic I’ve switched Xibo over to a linux server running docker.