Help required to improve the video quality from Xibo

The twitch streaming video quality is very poor from Xibo Windows client with 4k display and layout. However, the quality of the same video is much better when browsing directly from the display PC IE11/Chrome browsers. We have tested/tried using both web page and embedded media on Region timeline, but no luck. Is there any setting needs to be made at CMS console level to improve the quality? or any help is appreciated.

Assuming you’re using the 1080p 16:9 resolution that comes pre-defined, then what will be happening is the IE11 browser control will be sized to 1920x1080 pixels, and then upscaled to 4K output.

You need to base your layout on a 4K resolution if that’s what your output is, so that the Player isn’t having to upscale that content.

Pre-defined you mean display monitor? or Layout which we have designed as 4k.
Anyhow, we are using 4k monitor and tried with both 4K and HD resolution in windows display settings. Do we have to adjust each display PC local IE11 resolution? to use 4K or HD?
Attached the 4K layout config

Your problem is right there in the last screenshot.

The layout is 3840x2160 pixels, but you’ve defined the Twitch iframe to be 1920x1080, and then have Xibo zoom scale it up.

You need to turn off “Scale Content” and set the iframe to be the correct size 3840x2160

Thank you! I remember I tested that as well. Anyhow, will test again in a day or two and get back to you.
Also, CMS server is in remote/different Data center network than display PCs location. But, no issues with display PCs reaching to the CMS server. However does this cause slowness in streaming videos?

When you embed a website as you have done, that website doesn’t pass through the CMS at all, so it would only be the connection between the Player and Twitch that would be in play there.

Have turned off scale content and updated the iFrame size to 4k. Still the quality is poor :frowning: Any IE setting or registry setting needs to be configured on the display PC?

You could check that hardware accelleration is turned on.

HKLM\SOFTWARE\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_GPU_RENDERING

HKLM\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_GPU_RENDERING

Add a key there XiboPlayer.exe as a DWORD with the value Decimal 1.