Github no docker installation problem

hello i’ve a problem with my installation of docker on my ubuntu 16.04.4.

When i do this command the download start but it downloads nothing…
curl -L -s-uname -m > /usr/local/bin/docker-compose

thanks for your help

We would need to see what steps did you take exactly, what already is installed and where the problem is - perhaps screenshot of the console command would help.

Were you following the instructions form here ?

ie you have docker for linux installed?
but when you run the command for docker compose it did nothing? You could try running the latest command as stated in the manual, for your convenience

Hello thanks for your help but i’ve installed xibo without docker already and it’s working fine.
But the major problem right now is that the version is only 1.7.1 and some feature doesn’t work like the dashboard and most importantly a website region.

For the dashboard that doesn’t show the options:
For the website the first screenshot shows the region of the layout:
Then the result with the preview (that doesn’t show the website region):
And the settings in case i did something wrong:

I think all of those problem with be fixed in the next version (1.8.8) but it tried to use your tutorial here:
Then i understood that i just had to replace the xibo folden of the 1.7.1 in the /var/www/html/ folder:
by this 1.8.8 folder:
But then i try to launch the install of xibo for 1.8.8 and does not work…

Here is the list of commandf i did to install xibo:

So i have 2 options:
-fix the website region and the dashboard in the 1.7.1 version of xibo
-update xibo to 1.8.8 to hope to fix those 2 bugs

If you join me on discord if you want more details and the view of my ubuntu.

thanks for your help!

I might have the solution…
when i want to install xibo 1.8.8 i go to localhost/xibo/web/install
but when i installed 1.7.1 i went to local/xibo/install
There might be a problem of compatibility in some files then with the folder…

Now you’re not using docker at all?

If you have docker installed with docker compose then if anything you should be using these instructions

If you don’t want to use docker then yes the upgrade_custom instructions will apply, but custom installations require a little bit more configuration, please see
the document root and url rewriting must be correctly set and then related XTR and XMR as well.

Thanks for your reply.
I don’t have docker installed at all.

I did the tutorial of upgrade_custom now the problem is that when i try to install 1.8.8 i go to localhost/xibo/web i get redirected into /localhost/xibo/web/install and i get an error 500:

Then i watched the permission and everything seems fine:

It’s my first installation of Xibo so i don’t understand this quote: “the document root and url rewriting must be correctly set and then related XTR and XMR as well.”

Please do have a look at that link and you will know why you have /web in the URL and why is it incorrect.

i looked up and i changed the document root to /var/www/html/xibo/web but now i just do localhost i have the same problem:

Anyway it’s a good change for the website thanks!
I’ll continue to watched this tutorial it might the solution to my problem

Is url rewriting also correctly configured? (there are instructions for various web servers in that manual page).

i was watching the tutorial and i tried to find it but there is none.
Should i create .htaccess in the /var/www/html/xibo/web/ folder?

I find out that my /etc/apache2/site-available wasn’t update to /var/www/html/xibo/web/.
And now my ssh appears to be working so i tried to modify ;htaccess which appear to be an hidden file

It’s seems to be alright

It’s possible to get some vocal support?