GET/Display return null currentLayoutid

Hello,

I’m trying to see what layout is the display currently showing but it returns me that :


The display current layout is 790, I can see it in the status tab from the device but doesn’t recieve it in the call.

Any solution ?

Current Layout sending is disabled by default as it is bandwidth intensive - you can enable it in the display settings profile.

Yes I saw that on another topic. So I did it but nothing changed :confused:

Actually, the current layout is not even shown in the CMS, and the “Display current layout ID” are true in the display settings and in the display profil


In the settings of the display :

In the settings of the display profil :
image

Hmm, strange - i’ll move this into the support category to see if it can be solved. It does work on our test equipment so perhaps those settings have not yet filtered through to your device?

Is there a way to make sure they did ? Because everything else is working with layouts so the player does communicate with the server…

Could it be a problem with that ? : https://xibo.org.uk/docs/developer/player-api-overview

I don’t think it is a problem with the Player API - we have it working on many CMS instances elsewhere without any issue.

I think it is more likely to be a problem with your setting not getting applied as an override - can you try changing it in the Display Profile itself to see if it then applies? Instead of changing it as an override? Also are you using 2.0.2? (because it might be this :bug:)

So I’ve tried to change the settings on the display profile but it didn’t work either.

I was in v2.0.1 and I just updated my CMS to 2.0.2 but nothing has changed…

Hi,

I continued searching why the current layout id field was empty and I randomly found a file called display.frm in /opt/Xibo/xibo-docker/shared/db/cms (opt/xibo is where I installed the CMS). I typed cat display.frm and here is the result

Now if I look at the array below (the array that is returned when I send the command) we can see that all the fields that are not mentionned in the screenshot above are empty in the array…

So I was wondering if there was something to do with that file or the display.ibd file ?

Array
(
[0] => Array
(
[displayId] => 2
[auditingUntil] => 0
[display] => manor_scr2
[description] =>
[defaultLayoutId] => 71754
[license] => ef88dad3-4b9e-369a-927f-45cb7789ed83
[licensed] => 1
[loggedIn] => 1
[lastAccessed] => 1562577240
[incSchedule] => 0
[emailAlert] => 0
[alertTimeout] => 0
[clientAddress] => 192.168.0.18
[mediaInventoryStatus] => 1
[macAddress] => CC:4B:73:46:75:72
[lastChanged] => 0
[numberOfMacAddressChanges] => 0
[lastWakeOnLanCommandSent] => 0
[wakeOnLanEnabled] => 0
[wakeOnLanTime] =>
[broadCastAddress] =>
[secureOn] =>
[cidr] =>
[latitude] =>
[longitude] =>
[clientType] => android
[clientVersion] => 2
[clientCode] => 201
[displayProfileId] => 0
[currentLayoutId] =>
[screenShotRequested] => 0
[storageAvailableSpace] => 11622834176
[storageTotalSpace] => 12748505088
[displayGroupId] => 7
[currentLayout] =>
[defaultLayout] => defaultLayoutForSauna
[xmrChannel] => 633ef6c678d30a86782d12f1a2a578ca
[xmrPubKey] => -----BEGIN PUBLIC KEY-----
MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAtRs8xy5Xr+I6Crscu4ia/FL/PxF+YeKU
MVjFltx1FOkdjlbxq5LjcaavxNZJh5R+M4E0Fs/Cs8HwgrSRn0os1oI58Lm6OreSAUy+XNIyiIiu
uTfpFFDrB7EG9A0mU4J/Wy1Y4IL5FIUafwuUNs0efASOThNNSjCROTqJgjQLZuFvdHjpqsbs7cNO
KksA6j7Xx6tISohV/434jsO/BmtLxTTChICaeAe1KB7s69viU63jjF6N1hoeW/L9UWj/jt56ucIP
xipQ33ABXp0NgvW83vfRn/16k67D22N3GgD6HclMMNhJS1KsW+44M5bwmbVOlVNiAPv/4YOtGLuS
aexVkwIDAQAB
-----END PUBLIC KEY-----

        [lastCommandSuccess] => 0
        [deviceName] => 
        [timeZone] => Europe/Amsterdam
        [tags] => 
        [overrideConfig] => Array
            (
                [0] => Array
                    (
                        [name] => sendCurrentLayoutAsStatusUpdate
                        [value] => 1
                    )

            )

    )

)

Found another thing, I don’t know if I can qualifie that “intresting” or not at all…

I tried loading that WSDL file in a new SOAP project in SoapUI : http://192.168.0.21:5859/xmds.php?wsdl&v=5

Then I called the NotifyStatus request like this :

<soapenv:Envelope xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance” xmlns:xsd=“http://www.w3.org/2001/XMLSchema” xmlns:soapenv=“http://schemas.xmlsoap.org/soap/envelope/” xmlns:urn=“urn:xmds”>
<soapenv:Header/>
<soapenv:Body>
<urn:NotifyStatus soapenv:encodingStyle=“http://schemas.xmlsoap.org/soap/encoding/”>
<serverKey xsi:type=“xsd:string”>MY_PRIVATE_KEY</serverKey>
<hardwareKey xsi:type=“xsd:string”>MY_HARDWARE_KEY</hardwareKey>
<status xsi:type=“xsd:string”>{
“currentLayoutId”: “112043”
}
</status>
</urn:NotifyStatus>
</soapenv:Body>
</soapenv:Envelope>

When I loaded this page : http://192.168.0.21:5859/api/display?access_token=MY_ACCESS_TOKEN&displayId=2, I saw that the currentLayoutId became 112043, and the currentLayout wasn’t null anymore, but “l_u1_gp5_49041f0c0fbac5065b18a1569442a233” which is the correct name of this layout…

Also when I go in the display tab, I now see the name of that layout under “current layout”.

After finding that I believe that the player isn’t sending the current layout id ?

PS : all the others properties are correctly returned:

Maybe that will help figuring out what’s the problem…

Thank you for passing on your findings.

Very recently it was discovered that there is an issue with Current Layout information being returned for CMS 2.0. The issue related to a change that meant the type attribute was no longer being used, which stopped some check boxes from functioning correctly. An issue report was created and the development team have fixed the issue for 2.0.4.

Here is the report:

When testing this fix, Current Layout information was again being received correctly. When 2.0.4 is released, can you upgrade to that version and confirm if the issue is resolved in your CMS? There is not currently a confirmed release date but when 2.0.4 is released, there will be an announcement on the Xibo Blog:

Many Thanks.

Further to my previous message, 2.0.4 has now been released, which has the fix for the above mentioned issue. Here is a link to the Blog entry fir those that would like to upgrade to 2.0.4:

Many Thanks.

Hi, I’ve upgraded the CMS yesterday and it worked !

Best regards.

That’s excellent to know! Thank you by the way for all of the information you provided about this issue, it was very helpful for troubleshooting.

Many Thanks.

1 Like