Forgot password


#1

Hello, I know this has been done before, but I just don’t get it to work.

I have lost the password for the CMS running on Docker for Windows.
In this topic it is made clear to run a sql-command on the web-container.
But I really don’t understand how to do that.
Do I use a powershell to do this?
I have tried the first line, and it comes back with the name of the web container. So far so good.
Then, the second line docker exec -it <container_name> bash doesn’t do anything.
So, for now I am stuck.

Can someone explain me how to continue?

Regards, Peter


#2

The second line must do something. Can you send a screenshot when you get to that step?

If it’s Docker for Windows (as opposed to Docker Toolbox) then you’re right to run it in PowerShell.

You might find it easier to follow:



#3

Hi Alex,

Attached you fond the screenshot.
When I tpye the commando for SQL, I can’t type anything in the powershell anymore.
At the bottom left, I see: Running script / selection. Press CTRL+Break to stop...etc...

What am I doing wrong now?

Nice to hear from you,

Regards, Peter


#4

It looks right to me, but there should be output after that.

I’d try the instructions I sent you yesterday rather than Peter’s ones.


#5

Hi Alex,

Yes, it is Docker for Windows on my on PC. I am doing some tests before we buy a subscribtion for hosting and the Android license.

I have tried to follow these instructions, several times, but I just don’t understand how to connect to the database. I am familiar with MySQL (I use it for Joomla), but now I am stuck.

I hope you can show me the right way to do this.

Is it possible in the next release to create a "forgot username" and "forgot password" button?
It would be so much easier that way.

Regards, Peter


#6

Email based password reset is coming in 1.8.12, but likely wouldn’t help you because you’re unlikely to have email setup and working on a local test install.

If you look at the second article I linked, it explains how to connect to MySQL inside Docker.

If that doesn’t work (and it really should), then there’s something else wrong with the setup. If you’re just testing prior to looking at Cloud, why not setup a Cloud demo (it’s free) and test with that?


#7

Hi Alex, I finally managed to enter the CMS. I used the wrong Powershell :wink:

Now I get the next challenge. If I want to change the password i use:

UPDATE user set UserPassword = MD5(‘password’), CSPRNG = 0 WHERE UserID = 1 LIMIT 1;

and i get the next error:

MySQL [cms]> UPDATE user set UserPassword = MD5(‘password’), CSPRNG = 0 WHERE UserID = 1 LIMIT 1;
ERROR 1054 (42S22): Unknown column ‘‘password’’ in ‘field list’

Can you tell me please what I am doing wrong here?

Regards, Peter


#8

password needs to be in quotes


#9

Thanks Alex! That did it…

Regards, Peter