Font names show up in Japanese

Installed a fresh copy of Xibo 1.8.3 (manually on a webserver).

The font names that come with it (as well the ones I tried adding) show up in Japanese characters.

Settings → Regional → Default language is set to ‘en_GB’ (tried 2 different ones, no change in font name)
Detect language is disabled.

Everything else is in English, it is just the Name for file types ‘Font’. Type ‘Video’, ‘Image’ etc. do show the correct name. (although it is of course not possible to edit font name/description)

That’s rather interesting, I don’t think I’ve seen it before to be honest.

If you look in your CMS library (physically not in the browser) are those files with the Japanese names there as well?

Is there anything in your system set to Japanese?

I’v got the same bug version xibo 1.8.9, i’ve an external database mariadb in UTF8

I have this bug too, Xibo 1.8.9 with MySQL server, only with fonts. Do you have any idea on how to resolve it ?

Is there a fix for this yet?

Unfortunately we have not been able to replicate this issue. Can you confirm the following?

  • What Version of the CMS you are using?
  • Are you experiencing the same issue as the first post describes?
  • Is it only the Font names that are affected?
  • Have you made any changes to the CMS prior to seeing this behaviour?
  • How long have you been experiencing this issue for and is it intermittent?

Many Thanks.

Hi All,

I have the same issue :

  • version : 1.8.11
  • same issue as first post, yes
  • Only the fonts names are affected
  • No modification. Fresh install on a clean install on Ubuntu 18.04 LTS with PHP7.2 (mcrypt and zeromq installed via pecl)
  • Since the installation. no intermittence

Best Regards

I have exact same issue.
Xibo 2.0.0
Installed on Debian 9.6
PHP7 (also tried with 7.3 - same thing)
All required dependencies installed via apt, so current versions.
Font names (only names) in XIBO interface are in chineese/japaneese like OP showed. In xibo library those have normal names (10.otf, 11.otf etc for base fonts that come with xibo).
Uploading new fonts - also name is showed in chineese. Other media is fine, no issues.
This is a fresh install, no changes to Xibo were made at all.

Rather strange because it affects only font names in xibo interface (in media library), not names of uploaded files and no names of other media added to library.

Thank you for passing on the details of the Chinese/Japanese characters that are appearing for font names.

Can you confirm the version of MySQL you are running, where in the world your server machine is, the character encoding you are using and any other information about your setup that could help us to understand the issue?

You mentioned this is happening when Uploading new fonts, would you be able to provide troubleshoot logs when you are uploading a font? To do this:

  • Select the Report Fault option in your CMS.,
  • Follow the steps and select Turn on Debugging when the option is available.
  • Continue with the steps and select Open in new Window.
  • In the new Window, upload a font. Check the Media Library to confirm it was uploaded successfully and is appearing in the Japanese/ Chinese characters. If so, close the window.
  • Back on the original window, continue with the steps and select Collect and Save to create the log file.
  • Continue with the steps and Turn Off Debugging

If you can send me those Logs in a private message, I would be happy to take a look to see if I can find any clues as to what is causing this issue.

Many Thanks.

Hello ! is there any clue about this problem? I’m having the same issue, but the problem is that not only the fonts name are shown in Japanese into the Library, but also into the editor.
Nevertheless, some “system” fonts are shown correctly I don’t know if this can be a clue about permissions or some other questions.

The Xibo 2.0.3 CMS is running with a manual installation into this system
Ubuntu 16.04 LTS 64-bits
MySQL v14.14 Distrib 5.7.25
PHP v7.0.33

Tell me how can I help to debug this problem and try to fix it together.


I followed the steps of @DanBW to get the, I can’t upload the zip here but looking inside the log.csv, I found this

WEB|/library|POST|No pre-processing rules for this module type|
WEB|/library|POST|Font name adjusted to 䴀礀 琀礀瀀攀 漀昀 昀漀渀琀 刀攀最甀氀愀爀 and embeddable flag is 0|
WEB|/library|POST|Save for mediaId: |
WEB|/library|POST|Media Update happening now|
WEB|/library|POST|saveFile for "䴀礀 琀礀瀀攀 漀昀 昀漀渀琀 刀攀最甀氀愀爀" [19] with storedAs = "", fileName = "mytype.ttf" to "19.ttf". Always Copy = "", Cloned = ""|

Please let me know how can I help.
Thanks Again

Hello again, I’ve been searching inside the Xibo files and already fix the error at least for the new imported fonts, but I don’t know if this affect anything else.

The line is inside the /lib/Widget/Font.php Line 104

I change this

$media->name = $font->getFontName() . ’ ’ . $font->getFontSubfamily();

to this

$media->name = $font->getFontName();

and the font name is no more in Japanese, as I said, I don’t know if this change can affect another thing, please some Xibo developer can check this and let us know?.

Thanks Again!

Thanks for the investigation and suggestion - unfortunately if we remove the font sub family we get conflicts when uploading multiple versions of the same font.

We use this library to parse font information, it sounds like the problem might be with that library?

Thanks @dan for your answer !.

I think I finally nailed it, forget the last post. I run the docker version and check the different PHP modules installed in the docker version vs my manual version. The magic is done by one module php-mbstring

I installed that module with apt-get install php-mbstring and done !!.

I think the documentation about the dependencies
in the manual installation doesn’t have all the necessary information.

I hope this help to @bvdijk @Michael_Corlou @MehdiElMnadil @bwacks @pathof and @misioooo

and thanks to all the developers for this huge work !


Great!! we will update the document accordingly.

Thanks and happy Xibo’ing :slight_smile: