Finance module (https problem)

Hi guys, I was trying to use the Finance Module on my fresh install and when I clicked “request data”, there was a curl error. The same error I had with the Forecast IO that I had fixed with the latest cacert.pem as you explained.

The problem is that it doesn’t fix it for yahoo finance. So I checked over to find what was going on and I think Yahoo changed the access to their “finance queries” from HTTPS to HTTP.

See :

So i changed the https in the finance.module.php from https to http and it started working instantly.

Is this a bug? Or did I do something wrong that is so not secure that I shouldn’t have done it? :slight_smile:

By the way, I do believe that xibo is the best open source software I tried as of now. Documentation is great, I found documentation for every problem I had and everything worked. I used it for 2 weeks now, no problems, no bugs, nothing… Just that little finance module problem that I’ve been able to fix by myself.

Seriously, great software!

Thanks! Hope this post will help someone who has the same problem.


1 Like

The URL using https seems to be valid for me. I wouldn’t think that Yahoo would remove the ability to use a secure connection. Are you sure the cert you downloaded is up-to-date? I would recommend downloading the latest one from here, and then reboot your server.

Hi! I took the certificate from the site you point me to. I took the latest version, I even did it a couple of times, just to be sure I wasn’t crazy…

But did you look at this :

Why would yahoo point us to a site without https ? The adresses they give for the YQL queries are not https…

I couldn’t tell why it works for you, but for me it did not unless I changed that… But I’m a bit noob in that stuff, as you can see, so I may have done something wrong.

And as I said earlier, the “request data” button gave me an error and did not return anything, and as soon as I changed it, I finally had my “google quote”, with the appropriate data (I checked on and found that the data I had was the expected data…)

Server version : 1.7.9


I do see that the documentation does not mention https. This could be due to the age of the documentation. Yahoo does not provide a date that the documentation was last modified, so I can’t really tell.

What I can tell is that from any browser I have, if I go to say:*%20from%20geo.places%20where%20text="sunnyvale,%20ca"

I get a valid return. This also works without the SSL layer (http). So this does show that using https is valid. I would suggest you try from your sever to see if the same URL works with the https in your browser. My guess is it will.

If not then I would look to your firewall for the possible problem.

Oh I understand what you mean…

The fact that http works for me doesn’t mean that https isn’t working… and you’re the proof that https works for everybody else.

Knowing that, it’s quite clear that the problem is somewhere on my network… The weird part is that the forecast IO is OK with HTTPS. I’ll keep you updated if I find the problem. But as of now, I won’t be working on that, I only did that for testing purposes and to confirm myself that xibo was such a great product! :slight_smile:

Confirmed! :slight_smile:

Thanks for the troubleshooting!


Your welcome.

Xibo will take a huge leap forward, in my opinion, with the release of 1.8 when that happens. Lots of great improvements to already great digital signage solution.