Fetch Remote DataSets task does not run often enough

To be completed by the original poster:

CMS Version

Version 3.3.3

Player Type

Windows

Player Version

Include the full version, including the revision number.

Issue

Hi Folks, I have a remote CSV file that is updated every couple of minutes ( for context it is recording golf scores ) I have a remote data set set up and working, the issue I have despite asking for a constant update the Fetch Remote Data sets task only runs every hour.

Is there any way i can reduce the time interval to every 3 miniutes ?

I have the layout published / scheduled and cached for 1 minute

As I say it works and does update every hour but this is not the most exciting way to get live golf scores from the course :slight_smile:

Greetings. I am experiencing the same issue. Was a resolution ever found for this? Thank you for your support!

I believe the recommendation is 5 minute minimum, but as long as your platform is fast enough…

You’d have to change the cron job timing, so really this leads to what platform you have Cloud, Docker or CMS.

You have schedule available within Tasks using cronjob formatting i.e. https://crontab.guru/

You also have the cron job to check those which will depend on your hosting platform. You’re looking for XTR setup though here (for CMS) Xibo on a Web server | Xibo Digital Signage

Thanks 203 - i am using the cloud CMS , so not sure I have access to cron

Not sure if this is what you are looking for, but there are three different sections for this that I’m aware of.

(Server > External sync)
Tasks > Fetch Remote DataSets:


If you Edit the task, you’ll see ‘cron’ notation for how often it reaches out:

(Player > Server sync)
The second location for how often the data is refreshed is in the Dataset object. Edit the Dataset and go to ‘Advanced’ > Refresh dropdown:

(Player Layout cache)
The last location is within the layout itself. Select the Dataset widget assigned to the layout and navigate to the Cache tab:
image
(Note: Not sure why they recommend 60min for once per day and not 1440… but :man_shrugging:)

By combination of all three of these, you should be able to fine tune it to your preference without having too many requests both internally and externally.

Hi signage thanks for this, the issue is I don’t have an edit option at (Server > External sync)
Tasks > Fetch Remote DataSets:

I am runing on CMS cloud so unless I am missing something it appears this option is not available to me - i have al ready configured the other two options

Ah ah - Cloud CMS is fixed - ah well ill have to push the data then :slight_smile:

Ah, that would make sense then why you don’t see it. Hope you’re still able to make it work. If not, since you’re a Cloud customer, you could also reach out directly to Xibo support for direct guidance on the matter. Best of luck :slight_smile:

thanks again for trying

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.