Error while setting up Xibo with Docker - WIn 7 64Bit

I have followed the instructions and I am up to the section where I am ready to get to the web address however, its throwing up a page with an error that says: Fatal Error - sorry thos shouldnt happen SQLSTATE(HY000)(2002) php_network_getaddresses: getaddrinfo failed: try again.

Anyone know what the fix for this is ?


Can you try the fix suggestion in the below link to see if the issue is resolved?

If the issue persists after applying the fix, please let me know.

Many Thanks.

Hi. Where and what exactly do I change sorry ? I have edited the section I think it is suggesting but that hasnt work as I am unable to bring it back up. Very new to Xibo and I have never used Linux either. ANy help is much appreciated.


Sorry. Managed to edit it but still get the same error. Attached is where ive edited it.

New error now. See attached.

The new error suggests that you are not using a Password for MySQL. You should see an element within the config.env file named:


Have you set a password for this element? If not, you will need to add an alphanumeric password, approximately 16 characters in length. Please note you cannot use spaces or special characters when creating this password.

If you have already set a password, please let me know.

Many Thanks.

All resolved now. Thanks