Error When I try to add repetitions

Error When I try to add repetitions


When I try to add repetitions in the schedules, I get the message:

“The first event repeat is inside the event from/to dates.”

What is happening?

Xibo prevents you from creating repeat schedules where the end of the first repeat would overlap the start of the next, as that configuration is invalid.

To use a repeating schedule, define the first event that you want to happen - eg today between 8am and 9am - and then define your repeat - eg repeats daily every 1 day until a date in the future.

What you’ve done is put the date you want the repeat to finish in the first tab, rather than the repeat tab. If you do that, what you’ll end up with if Xibo allowed it, would be lots of repeats of the same layout schedule all overlapping one another.

1 Like

Hello Team,
I have the same problem and the answer do not resolve what I try to do.

Here what I try to do:

I have:
Layout “L300” with a text duration at 300 seconds.
Layout “L45” with a text duration at 45 seconds.
Layout “LV” with a video and a duration of 0 second. (so the layout finish when the video is finish.)

I putted L300 and L45 in the scheduler with no repeat.
The display client show; L300 for 300 seconds, then show L45 for 45 seconds. (everything is fine)

I’m trying to put LV in repeat every hour for the time of the video. (92 seconds is the time of the video)

I tried like you said:
Put the start date at 15 Nov 19H45pm and end date at 15 Nov 19H50pm with a repeat every one (1) hour.
The video started and at the end it’s restarted. I guess I would have last 5 minutes… Which I would like to avoid.

Can you tell me how you would archive this setup?

Thank you!

With it configured as you say, the video will repeat between 7:45 and 7:50pm. Because your video is 92 seconds long, it will show about 3 times in that period.

If you only want it to play once, then you’d need to reduce the length of your schedule - so from 7:45-7:46pm

The UI only allows you to click for 5 minute intervals, but you can manually type in the finish time after you’ve chosen the nearest option.

I thought I tried that. Didn’t do it correctly.

So I put it for 2 minutes and it restart for 28 second. I can’t get it better. right?

Thank you

Are you doing this as a priority schedule?

If so, try turning priority off, and increasing the size of the schedule.

So for example, say your other running layouts last 5 minutes in total, schedule it for 6 minutes without priority. That way, at some point during the cycle, that layout will play in once, and then the next time it’s due, it’ll be outside the schedule again.

Otherwise, you’ll have to pad the video in your layout with other content to make the layout last for 120s total and schedule it as you have it now.

Thank you,
I will Pad it.
To much management when having multiple layout + the video one.