Error sending commands

Suggests there’s something in the display name perhaps that the system doesn’t like. What is the display called?

The displays are all named similarly:


It’s not display names then. You’d need to enable auditing to see what is throwing that error.

If the call to register isn’t working properly, then the chances are your new command definitions aren’t being pushed down.

I’ve enabled auditing, and the errors are happening during 11:36 as seen here

however here is the output of the player during that minute, is there something I am missing?

Interestingly I have removed the command entirely from the CMS, now all players are reporting as Logged in. I’ve verified this by re-adding the command and then deleting it again.

The command name is simply Shutdown and the command itself is as seen in the previous posts.

This seems to happen regardless of how I configure the command, and the start notepad command which previously worked for me is causing the same error message.

The following works for me.

Command definitions

Display profile settings:

So I firstly add the Command Definitions. Everything is fine, players report as logged in, even after waiting ~10 minutes or so.

As soon as I add the settings into Windows display profile, and wait for 2 minutes, all displays are Logged off. Then I send command to player and get the same error as before. There is nothing new in the Client Information panel that I haven’t already posted.

I’ve copied exactly, to a tee, the settings you have posted. I’m not having any other problems at all, even screenshots etc are working fine.

Please put the CMS in to audit mode, and then see what it logged in the CMS logs when a display registers.

When the player “unregisters” - or when I add the command into the Display profile, I get this error in the player

How do I put the CMS into audit mode, in Settings > Troubleshooting?

Yes in there, you need to put the error setting to audit, and set auditing until to a date in the future.

I don’t have an audit option for the CMS only for the players, is it likely to be Info or Debug?

Thanks for all the help so far

Please select debug. You should’t adjust the resting log level.

Just spotted this after removing the command info from display profile settings (essentially forcing a re-register of the player)

I’m not sure what you think that log message is showing, but it looks entirely normal to me.

I’m showing any information I can to identify a potential problem. I honestly don’t know what it’s showing, normal or abnormal, as i’ve never enabled this troubleshooting mode on the CMS.

All I can find for Page /display in the logs for the time where the player is registering is this

Display times out after populating a command, comes back when clearing command. I’m not sure where to go from here.

From what you’ve said thus far, it looks like adding those commands to your display profile is causing register to fail to return, due in an invalid character.

To diagnose exactly what/why the character is invalid, we will need auditing to be enabled on the Display in question (not on the CMS). Simply edit the display and on the advanced table put an auditing until date in which is ahead of now.

Once you’ve done that, recreate the error state you’ve been experiencing and look in the log. You can filter the log by your display using the filter.

EDIT: this could be due to the command itself, or a space/special character in your command code.

Please post a screenshot of your “Commands” page from the CMS.

When the register fails

When it succeeds

I can’t find anything clear for the register event but it doesn’t give me the invalid character error.

CMS > Displays > Display Settings > Commands when the players will actually register

CMS > Displays > Display Settings > Commands when the players will fail with invalid character

CMS > Displays > Commands always stays the same

I have been testing with only one command at a time.

“shutdown player” isn’t a valid code.

You need to use a single word, without whitespace. See in my example it’s just “shutdown”

If you leave a command undefined in the Display profile, then it isn’t sent to the Player. That’s why it’s only problematic when you set a value for it.

I suspect you’re running an CMS version older than 1.8.3, as the validation was adjusted to prevent that.

1 Like

That is interesting - validation has been added to the command page at some point, which prevents you from adding new commands with a reference that contains a space.

You would now get a message which says “Please enter a code between 1 and 50 characters containing only alpha characters and no spaces” if you tried


1 Like