Error on Xibo 3.1.4 - symfony\polyfill-php80\bootstrap.php


We have been using Xibo for a number of years on a local Windows Server 2016. This was working fine until we recently upgraded to Xibo 3.1.4 from 2.0.0, following the procedure provided.

The system upgraded fine and is up and running, but whenever we try to edit a Layout and then save, we now receive the following error:

Parse error: syntax error, unexpected ‘:’, expecting ‘{’ in D:\xibo\vendor\symfony\polyfill-php80\bootstrap.php on line 23

We’ve tried changing the PHP version from the original 7.2.7 to 7.3.25, 7.4.13 and 8.0.0, but none of these seem to solve the issue. These have all been configured with the php_intl.dll and php_mbstring.dll libraries, as I read elsewhere on the internet these might be needed.

Given the Composer libraries come bundled with the build, I’m reluctant to try upgrading these autonomously, as I would assume these have been set to be compatible with the Xibo build.

Any guidance would be most appreciated.


I assume you have a backup, so restore the backup and try upgrading to version 2.3 then 3.0 and then 3.1.*
If you have a custom installation It may be that some pages do not load correctly, so try increasing the ‘Maximum Query String (Bytes)’ to 8192 in your website server configuration file (web.config or .htaccess, or similar)

Or you can just follow this topic which is very useful for custom CMS migrations

Thanks for this. I’ve just tried increasing the query string limit in IIS, but that does not seem to have worked. Further to the above, I have also checked that all prescribed PHP modules are in place and I did migrate up to the current version in the sequence prescribed. I have also tried replacing all files again with a fresh set of 3.1.4, retaining only web/web.config and web/settings.php, but to no avail. Any further support would be appreciated.

I can agree with @pitoco02 that those steps are the correct upgrade steps. I had the same issue with web files not showing properly + database errors.

Just replacing web files is not enough if the database is not upgraded correctly.

The website was upgraded at each step, using the phinx script, so it wasn’t that. It actually turned out to be the fact that not all verbs were being allowed since a PHP upgrade. All now sorted. Thanks for the contributions.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.