Error in 1.8 installation in Ubuntu

hello.
im following this guide which is posted by mr.alex to Install xibo cms (1.8) on Ubuntu.
1.8 installation guide

im encountering the following error when i run the command “sudo apt-get -y install docker-ce” (the bold ones) :
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package docker-ce is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘docker-ce’ has no installation candidate

what’s the problem? im a complete Linux noob and i don’t know what should i do differently.any help would be appreciated.

You probably missed one of the prior steps.

Please check that each of the previous steps (adding the docker repository, and updating your apt lists) worked as expected.

Also ensure you’re using a 64 bit version of Ubuntu 16.04 as is required for that guide.

i have the 64bit version of Ubuntu 17.04. it’s not 16.04 unfortunately so is that the problem?
i also checked the prior steps and they were all correct and “done”.

Docker don’t package for Ubuntu 17.04 which is why it won’t install for you.

You need the versions outlined in the guide.

oh . alright. thank you sir . much love :wink:

hey there again.
i have another question. Can i install xibo 1.8 and docker on ubuntu 15.04 ? or it’s just doable on 16.04?

Docker only package for LTS versions of Ubuntu.

LTS versions are supported by Ubuntu for 5 years on server, where as non-LTS versions are only supported for 18 months I believe.

So for any system you intend to run for production, you should be using an LTS version - ie 14.04 or 16.04.

To use the guide, which is written for Ubuntu 16.04, then you want to be using 16.04.

1 Like
The Xibo Community site uses cookies. What are cookies?