Error: "Activity threshold exceeded. There are 1 processes"

Player Version



The player is showing the Xibo splash screen. Initially, the player was on R305, so I tried updating to R308. However, after updating the player, the problem persisted. After looking at the logs, it’s saying that the activity threshold has exceeded. I know this means that there is more than one process of Xibo open on the machine, but the problem is that there is only one Xibo process open, and the watchdog. I’ve tried to scour through the task manager’s processes list and close all processes relating to Xibo. When I try to reopen Xibo, the same issue still occurs.

I also saw that there has been a previous post about the same issue:

However, it doesn’t seem to have been resolved on their end.

Any ideas as to why this is occurring?



HI, could you provide a screenshot of the Player status screen?


This is what appears.

Thank you for providing the status. The DNS name for your CMS does not resolve so that be could a network error or a problem with your DNS server, which you will need to investigate further.

Thank you for your reply.

I’m unsure that’s the case, since it is still able to connect to the CMS. For example, when we reconfigured the player after updating to 308, the player had no issues connecting to the CMS. Wouldn’t the player have issues connecting?

I also thought that maybe the machine had no network connectivity, but the machine reports to the CMS as online. From what I’m reading in the logs, it’s saying that there are more instances of Xibo running, but there’s only one instance. Just a strange issue, and I’m wondering if it may be a bug.

The error shown in your screenshot is saying the player cannot connect to the CMS. If you are seeing that error all the time then the the Player is not updating from the CMS.

The logs do not say that there are too many instances running. If that was the case the message would be Killing process - process count threshold exceeded. The log message you are seeing is because the Player has stopped talking to the CMS because the DNS name cannot be resolved.

I hope that clarifies the situation for you.

Thank you for your response.
I went to check the player status again this morning, but it looks like the DNS error has gone away. However, I’m still experiencing the issue.

Here is what the log in the CMS shows.

Any ideas what the issue is? Would it still be the DNS if there is no DNS error?

I have found a fix! Deleting the Xibo Library folder and forcing Xibo to redownload the content seems to have fixed the issue. Maybe there was some sort of corrupted data that was there previously.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.