Embedded Youtube - but Muted

In the CMS settings, what are your XMR public and private addresses set to?

Still get the same error for the wget command.

Priviate - tcp:://localhost:5555
Public - tcp:://localhost:5556

Private should be


Public should be the DNS name or IP address that you access the CMS at (as the Player sees it)


You definitely downed the container and recreated since the reboot? The correct DNS server IP for your network is in the json file now?

the container was down when i rebooted, i couldn’t get it back up, that’s why i re booted.

I’ve put those address is but I’m still getting the operation timeout.

Th nslookup test on the link you gave is returning a can’t resolve google.com when I try it

what link did you try please?

What exactly do have now in XMR public and private addresses?

Priviate is - tcp://xmr:50001

And public is tcp://

Did you try to fix that DNS issue as described in that post?

If you mean by creating the daemon.json file with my dns server in it then yes I did

I can get the container to start again now, same error as earlier

Ok, fixed that one again, service didn’t start for some reason

So what’s the state now? Is nslookup working or not?

No, still not working this morning

I’m pretty sure its still a dns issue, I can ping bbc.co.uk for a normal terminal, I can ping from within the container using
$ docker run busybox ping -c 1

but I cannot ping www.bbc.co.uk using

$ docker run busybox ping -c 1 www.bbc.co.uk

Also if I add the --dns “serverip” in it works.

I am having trouble restarting the docker services as mentioned on the page linked


The service doesnt seem to want to start when the daemon.json file is there form what I can make out

If I try to start or restart the docker service with the daemon.json file there I get this as a result

Job for docker.service failed because the control process exited with error code. See “systemctl status docker.service” and “journalctl -xe” for details.

The systemctl says

● docker.service - Docker Application Container Engine
Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: e
Active: failed (Result: exit-code) since Fri 2017-04-07 09:05:16 BST; 18s ago
Docs: https://docs.docker.com
Process: 8047 ExecStart=/usr/bin/dockerd -H fd:// $DOCKER_OPTS (code=exited, s
Main PID: 8047 (code=exited, status=1/FAILURE)

Apr 07 09:05:16 signage systemd[1]: Starting Docker Application Container Engine
Apr 07 09:05:16 signage dockerd[8047]: time=“2017-04-07T09:05:16+01:00” level=fa
Apr 07 09:05:16 signage systemd[1]: docker.service: Main process exited, code=ex
Apr 07 09:05:16 signage systemd[1]: Failed to start Docker Application Container
Apr 07 09:05:16 signage systemd[1]: docker.service: Unit entered failed state.
Apr 07 09:05:16 signage systemd[1]: docker.service: Failed with result 'exit-cod

Yes I’m pretty sure it is DNS related.

What I can’t work out is why the steps in that article aren’t working for you. The fact Docker won’t restart suggests that there’s an error in that file.

What is the exact content you’ve put in there?

Here, I’ve done the following:

sudo nano /etc/docker/daemon.json

In that file, I’ve put exactly

    "dns": ["", ""]

Then I restarted the Docker daemon

sudo service docker restart

Then I get the DNS server configured correctly:

docker run busybox nslookup google.com
alex@alex-desktop:~$ docker run busybox nslookup google.com
Unable to find image 'busybox:latest' locally
latest: Pulling from library/busybox
7520415ce762: Pull complete 
Digest: sha256:32f093055929dbc23dec4d03e09dfe971f5973a9ca5cf059cbfb644c206aa83f
Status: Downloaded newer image for busybox:latest
Address 1:

Name:      google.com
Address 1: 2a00:1450:4009:811::200e lhr25s15-in-x0e.1e100.net
Address 2: lhr35s01-in-f14.1e100.net

Well I’ve done it your way and its worked a charm, dns pinging, ticker data being populated.

Must of not liked the way I did it, I created the file by browsing to the location and right clicking and creating a new empty document then editing with gedit.

Thank you so much for your on going help with getting me up and running on docker and all the other issues, I guess your patience is wearing a bit thin with me but i really appreciate it.


Glad we got there in the end!