Embed Widget no longer works on v3.0.6

We recently upgraded to Xibo v3.0.6 from v2.0.6. On the older version, we embedded a HTML script that played a video at random that was saved on our intranet. Now that we upgraded, the script no longer works.

When I opened the Layout and clicked on the Embed widget, the script was still there, but when I edited it, it wouldn’t save the new code and instead deleted all the old code. Nothing saves. I even tried to embed a simple “Hello World” text in white coloured font but that doesn’t work either.

For clarity, I am using the Embed widget, going to Templates, writing the ‘HTML to Embed’ box and the ‘HEAD content to Embed’ box. Whatever I type is not there after I click on save.

Can you help? Thanks.

EDIT: I have just checked some otherwidgets and the Clock is no longer working either.
We also have multiple displays and the display running an older client is picking up the HTML embed, but not the clock. Meanwhile another display with the most recent client is not picking up either, not even the clock overlay…

Update. Our PHP was an older version We have updated it which has fixed the issues with the clock, but the issue persists on our display with the older client. However, it has not fixed the issue with the HTML embedded video (which the older client DOES display).

I have checked the previews on the Layouts and both the clock and the HTML Video work…

I think the main issue is every time I go to make changes to the HTML and hit save, it deletes it all and sets the default “< span style=“font-size: 48px; color:#ffffff;”>Enter text…< /span>”. It’s like there is something preventing me access to the embed widget?

So we managed to get it working by down grading our client from 3.302.4 to 2.0.201. We tried 3.1 and 2.8 which did not work.

The issue above with the issue on the HTML embed not saving needs to be resolved as I will need to add to it in the future.

The post below solved the issue for us: https://community.xibo.org.uk/t/unable-to-save-edit-settings/11474

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.