Email Notifications

I just want to say first that I followed the instructions at Xibo CMS Post-Installation Setup Guide. I am trying to get email notifications set up, but am getting errors related to the email address.

When I first set up the CMS, I did not set any email settings in the config.env file. If I’m not mistaken, I need to go back and get that configured correctly. How do I go about changing those settings post installation or does it require a fresh install?


You should be able to edit the config.env file to add the email settings and then just restart the services for the settings to take effect.


As @ltaylorwarren says, edit your config.env, add your credentials, and then restart the containers:

docker-compose restart

Don’t forget to add the -f switch to that if you’re using custom ports or remote mysql - eg

docker-compose -f cms_custom-ports.yml restart

If you’re using GMail, then you may need to allow access for less secure apps in order for things to work:

Thanks! I just have to get my settings done correctly. I’ll have to talk to someone else about our SMTP server to do that.