Docker toolbox on 64bit Windows 2008 r2 server

I am running a VMware 64bit Windows 2008 r2 server. I have loaded the docker toolbox on the server, but every time I try and boot up the virtual box I get an error saying "this kernel requires an x86-64 cpu, but only detected an i686 cpu. Unable to boot"
The physical computer has Intel VT-d turned on in the Bios and the VMware properties are set to use Intel VT . How can I get this to boot?


If you go the Virtual Machine Settings.

Clock on the Processor in the Hardware - Device Tab then it will display the Processor Details on the right hand side.

In Virtualization Engine tick the ‘Virtualize Intel VT-x/EPT’ option.

The VM which is running Windows Server 2012 cannot utilise the Intel VT because it’s not ticked for the VM.

I got the Virtual Box VM running using this setting in VMWare Player on my laptop.

Hope that helps.


By all means try what @smunir has suggested, but the error implies that your install of Windows 2008 Server is 32 bit, in which case it isn’t going to be able to run a 64 bit VM required for Docker to run.

Agreed if it is a i686 cpu it won’t run docker but it also won’t run the 64Bit Windows Server 2008 R2

@ca2helpdesk did say “I am running a VMware 64bit Windows 2008 r2 server” so please confirm if the VM is running 64Bit Windows Server 208?

My apologies in that case.

No need to apologise Alex. As ever your assistance is appreciated.

Thank you for your help. That did the trick and I was able to get Docker going on my server.

Whoa. How did you get those option on your VM? I’ve got a version 8 VM running on VSphere 5.5.0 and those options simply don’t exist. The VMHost has a Xeon with VT-x, but I can’t pass it on to the VMs.

I had to forgo Docker and do a manual/custom install. Do you have a different version of Vsphere?

[Edit] Never mind, I see now. That option isn’t exposed until the VM is upgraded to a version 9 or higher. :expressionless:

make sure that the physical host has all the VM options turned on in the physical host’s BIOS.