Docker install on Ubuntu can't find config file

Hi,

So I installed Ubuntu 24.04 on an older Mac Mini to use for a Xibo demo.
I’m following the steps from the community post Xibo CMS with Docker on Ubuntu 22.04 but when I want to run “docker-compose up -d” I run into errors.

First of all it says “no configuration file provided: not found”.
So I added the -f flag “docker-compose -f config.env up -d” and got the error “stat /var/lib/snapd/void/config.env: no such file or directory”

So I added the path to the file “docker-compose -f /opt/xibo/config.env up -d” but I still get the error
“stat /opt/xibo/config.env: no such file or directory”

When I run the stat command myself with the samen user (root) I do get results:
root@xibo:/opt/xibo# stat /opt/xibo/config.env
File: /opt/xibo/config.env
Size: 4731 Blocks: 16 IO Block: 4096 regular file
Device: 252,0 Inode: 4849676 Links: 1
Access: (0664/-rw-rw-r–) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2024-05-15 06:42:10.942009035 +0000
Modify: 2024-05-15 06:41:24.360893355 +0000
Change: 2024-05-15 07:06:44.989894979 +0000
Birth: 2024-05-15 06:41:24.360893355 +0000

I copied the file to another folder ( /home/xibo) and when I ran it from there I got another error:
root@xibo:/opt/xibo# docker-compose -f /home/xibo/config.env up -d
parsing /home/xibo/config.env: Top-level object must be a mapping

Can someone point me in the right directory with this? I’m running out of skill

You’re using the snap of docker/docker-compose and that can’t see outside of your home directory.

You need to move /opt/xibo in to /home/xibo and then docker-compose up -d

If you want to use -f then it’s the path/name of the docker-compose.yml file, not config.env.

2 Likes

Thx! been struggling for a couple of hourse now.
So I now manually installed docker instead of the built-in docker installation in Ubuntu. All’s working great now. Thanks!