Display problem in v1.7.6/v1.7.5

To the Xibo Support/Community.

Dear readers.

I have created a couple of dynamically generated webpages
which have been tested and found to work correctly under

Edge v25.10586.0.0
Internet Explorer v11.103.10586.0 upd.v11.0.28
Mozilla Firefox v44.0.2

all running under Windows 10 pro 64-bit.

The URLs of the pages are


In short the pages are reading information from the URL


picking out some of the information and presenting it in a
different format.

However, when displaying one of these pages from the Xibo-player
client v1.7.6 or v1.7.5 for Windows the pages are displayed

The Xibo-player client v1.7.4 displayed the pages correctly.

Because the pages are displayed correctly from several browsers
it makes me wonder if some errors have been introduced into
Xibo-player v1.7.6 and v1.7.5 and if they shouldn’t be fixed?

Another minor detail is puzzling me: The Xibo-players version
is found via the Help-About menu and is shown as e.g. 1.7.6.

If I want to uninstall the client I go to Control Panel-Programs
And Features where the Xibo-player is shown as having version

Why are the version numbers not identical?

Kind regards
Ib-Michael Martinsen

If it’s working fine in IE, perhaps browser emulation registry edit is missing? Enabling HTML5 in the Windows .net Player

As for 1.7.16 it has something to do with how Microsoft (.net) is assigning versions numbers.

That’s interesting, perhaps @dan could shed some light on it when he will have a moment.

It is 1.7.16 because 1.7.0 was alpha, then beta, then rc, etc - once I realised we’d come out of sync I jumped up by adding a 10 to the end.

From 1.8 onwards the player versions will not be connected to the CMS point release and we will ensure that a “1.8 player” works with a “1.8” CMS without worrying about the point release - letting us release players independently from the CMS.

on to the problem at hand
The only significant change between 1.7.4 and 1.7.5 in the player is: https://github.com/xibosignage/xibo/issues/568, which fixes a bug where the player wasn’t obeying the “Open Natively” setting.

To go back to the way it was loading before, you’d need to select “Manual Position” and leave all the defaults.

Hi Peter and Dan.

Sorry for the late feedback, but I haven’t had the time to test your suggestions until yesterday evening. I am happy to say they both worked.

Thank you very much for the quick and usable answers.

Kind regards

We’re very glad to hear that. :smile: