Disable Xibo Player auto restart in Windows 10

I have installed Xibo 1.7.7 player in Windows 10 PC and it works fine except from the fact that when I close it, it auto restarts after a few seconds so I had to uninstall it in order to be able to work. I have found settings to disable auto restart but there are only for Android profiles. How can I disable auto restart in Windows?

Thank you in advance.

1 Like

I think you probably mean 1.7.8 as 1.7.7 has no automatic restart functionality.

To close it once running, you need to close the Xibo Player application, as well as the Xibo watchdog application - which you can do from the system tray or from Task Manager.

If you want to have Xibo be able to start, but not automatically restart, then you can try renaming the Xibo watchdog application executable in the Player installation directory. That should prevent it being run and prevent any automatic restarts. I’ve not tested that though so I can’t promise it will work.

We really intend the Player to be a dedicated machine running the Player application - hence the automatic restarting.

1 Like

I’ve created an FAQ for you on the subject here:

Thank you very much for your reply.

An easier option (in Win10) is to RIGHT click the status bar at the bottom and click TASK MANAGER,

Select the START-UP tab.

Find and highlight the XIBO application by clicking it. Then click DISABLE bottom right. Next time you restart the PC the watchdog application will not start but you do not have to rename anything nor uninstall it. This applies to any start-up application by the way.

To restore the auto-startup functionality, do same but instead click ENABLE.


I’m afraid I don’t think that’s the case.

When you start the Xibo Player application, if the Watchdog executable is there, it will automatically launch it. Once launched, it will automatically restart the Player if it’s closed.

To avoid that, you need to rename the watchdog application per the guide.

As I understand your instructions, all you’re doing is preventing Xibo itself being launched at startup, which will work as you expect until you subsequently run the Player application, and the watchdog is launched.

Apologies. I note earlier this refers to 1.7.8. The version I use (1.7.6) obviously does not have this functionality. I would like to see the installer differentiate between a system used for development and one used to play the presentation. This could stop both this problem and the XIBO player auto start-up problem.

But I do love the software, with all its quirks, and have it running on 5 displays in a fish and chip shop without any problems (other than Win10 keep wanting to update itself even though I have told it not to).


Agree with John… I think Xibo players automatically starting AND the use of the watchdog at all should be configurable. Sure, they should be configured as they are by default, but I would like the ability for them to be started with a double click / CLI command.

Also, John is actually correct (I just tested it). The Windows 10 Task Manager groups tasks by vendor, so when startup is disabled for Xibo, it is disabled for both the Player AND the Watch Dog process, creating the effect the original poster was after.

The watchdog is NOT started by Windows. When you launch the Player, the Player then launches the watchdog.

Not auto-starting the Player will not stop the watchdog being started when you start the Player. The instructions in the FAQ article are correct.