Disable Hotkey on screensaver?

How do I disable the hotkey when only the Screen saver is configured, since by default when pressing the “i” key an informative menu appears, (even if the screen saver is not running, this annoying screen will appear if you press the "i"key)

How do I disable that option?

You can change it in Display settings page -> Edit display profile -> Troubleshooting tab -> Key for Client Information Screen

You can also enable ‘CTRL Key required to access Client Information Screen?’ on the very same tab.