Difficulties connecting Xibo Player Android to Xibo CMS


#1

Hello, I’m having trouble connecting Xibo Player Android to Xibo CMS, I’m currently running tests with 3 different OSs running CMS, I have Linux machines with Ubuntu, Linux CentOS and Windows 10. Of the three machines mentioned, the one that worked best was Windows even more so the difficulty is great in connecting is falling all the time and has
problems in receiving Layout. My Android Player is running on an Android Box connected to a Wi-Fi network where communication with the CMS machine is OK.
Could you help me solve this problem?


#2

Thank you for the background information about your setup. Can you provide me a screenshot of the Status Page on your Android Player? To access the Status page, click on the screen while Xibo for Android is running and choose Status from the Action Bar at the top. You are welcome to send this to me privately if you would prefer.

Can you also confirm the Model of Android device you are using to run the Xibo for Android app on?

I would recommend using a wired connection for your Player to see if the performance is improved and the issue resolved.

Many Thanks.


#3

I’m sending you photos of the status of an application that failed to connect, the device model is the Android Box TV model: TX2. In issue of the wired connection is impossible because the property is large and the location of the player does not have a network point!


#4


#5

Thank you for the screenshots. Your CMS address includes /xibo/ after the IP address. I would recommend removing the /xibo/ from the end of the address and trying to connect again.

If the issue still persists, please let me know.

Many Thanks.


#6

So if I remove the / xibo after the IP address it will not be possible to connect because it will fall on the localhost of the machine ie the Apache web server…


#7

The screenshots you’ve sent show that the Player is connected to the CMS successfully.

What’s the issue you’re seeing please?


#8

I checked the status and it really shows that it is connected, so I thought it could be port 80 blocked for some reason, so I changed on my web server the port from 80 to 8080 so the access link getting IP: 8080 / xibo so connected fast and also received the quick layout … I believe that the problem has been solved for the moment, I will run some more testing until the end of the day to see if it solved completely if I solve this topic…


#9

Unfortunately the first device continues to lose the connection which is what I need it to work! See photos


#10

Your Android device is shown as logged in and up to date in the screenshot.

Your other Player has no default layout assigned. Please ensure you set a default layout.


#11

Hello Alex,
We have the same problem



#12

According to your screenshots, many of your Displays have not connected with your CMS for quite some time.

Can you provide Status screenshots for your Displays in a new post please? This way I can respond to your issue without adding to this users query.

To access the Status page, click on the screen of your Android device while the Xibo app is running and choose the Status option from the Action Bar at the top of the screen.

Many Thanks.


#13

Our displays are installed at 4 different locations. The first one Mill8 showed only the standard display. So I solved this problem by adap\ting this standard layout including several ID’s… The M8S we used for testing and is connected to the LG television or Bauhn television. Cause there was no CMS connection we removed the dispaly to start again connecting to the CMS… there’s no connection to make… license is okay- by entering the CMS key …doesn’t give the solution. connecting the address manually in the device’s browser is accessible…


#14

printscreen before removing from display CMS > M8S display:


#15

We use Version 1.7.9…On the last printscreen Minix Neo U1 are showing the campaigns …


#16

Thank you for the screenshots. Can you attempt to log into the CMS on the Android Players, using the built in browser and confirm if there is any issue accessing the login page?

Many Thanks.


#17

What version of Android are you using?

Your SSL configuration is incompatible with Android versions earlier than 4.4.2 (and potentially Android 5 in or 6 in some firmwares).


#18

I ran several tests from yesterday to today in my network, servers and router have created up to local servers in the same ip band and everything. I am an analyst of T.I and look hard to give up something, more of this I’m almost giving up, I’m with the same error Cecile quoted above and my android is 7.0


#19

Version 1.7.9 | For the 4 deviced I use embedded pictures linked to the xibomediamap…
Former collegue has installed the xiboboxes.


#20

I ment Minixboxes…My profession is graphic designer…My companion did the technical stuf… We use different displays The boxes show the standard layout instaed of the scheduled campaigns. 4 different campaigns…