Dataset filtering by string


#1

Hello

I have some issue with creating layout with ticker connected to dataset. My dataset looks like below image. On layout I’d like to filter records based on dates and rook name. So I use SQL filter like this:

Sala LIKE “Roza” AND NOW() > Start AND NOW() < Koniec

Unfortunetly it is not working. When I reduce filter to:

NOW() > Start AND NOW() < Koniec

I works fine.What can be the reason of such behavior?


#2

two things:

  1. Have you tried to query that on mysql?
    Use the dataset id to query dataset_“id” table.
  2. Have you used a column with “content list”? It it is defined like “NOTE, ALARM”, that space between comma and ALARM is used and user entry gets saved like " Roza".

#3

Thanks @Dario_P :slight_smile:
" " between positions in list content was the problem.

When I’ve changed “Azalia, Dalia, Lilia, Malwa, Meander, Roza” to “Azalia,Dalia,Lilia,Malwa,Meander,Roza” in column definition it has started to work correctly.


#4

Be careful to not use accented or singular characters on dataset fields name, because tickers do not handle well (last version forbids to use them, but up to 1.8.10, you don’t get any warning)
I think you can mark it as solved and help the community.