DarkSky thumbnails and icons

The layout icons do not appear under the Appearance tab and then the icons for the weather do not show in the preview. I have checked just about everything. This is also a new install. My old install on another machine works fine.

This was a problem with 1.8.5 - please can you upgrade to 1.8.6 and then go to Modules -> Verify All, which should install the icons/thumbs at the correct location.

The icons in the Preview are now displayed. The icons for Weather Template in the Appearance tab still do not.

I’m sure this is what you mean, but just to check - these ones?

Yes. Those are not displayed.

same for me. have upgraded to 1.8.6 now and verified all, which passes, but still do not have those thumbnails, just broken image links. Doesnt affect the actual output on the layout though.

Are these Docker installs, or manual?

If manual - can you check for the presence of files in:

  • /modules/forecastio
  • /modules/forecastio/template_thumbs

You should find a json file for each template in the list, inside that file you should find an image path, pointing to the associated image in the template_thumbs folder

They look like they are in the release archive so I see no reason why they shouldn’t be…

This is a direct link for one of those images - in a logged in browser you should be able to get to it - it shows the binary image data.


This is a manual install for Windows.

OK sure - no problem. My following questions are applicable then.


The files all check out in the correct locations. I did open the link and saw binary data. I even looked at the json file and it had the correct path to the thumbnail. Is there a browser plugin needed? It just does not make sense. Thank you for all the help so far.

You’re right, it does not make sense.

Do you know your way around Developer Tools in Chrome? If so you could open developer tools and inspect the template selector to make sure that the URL’s its trying to use to load the images are the same as the ones you’ve just checked.

If they are, then I am really at a loss.

You could try the “Disable Cache” button on the Network tab of developer tools to make 100% sure you’re seeing the latest code.

There is a get error 404 for the thumbnail. The xibo/web is duplicated in the link below.


web shouldn’t ever be in the link - this implies an issue with the configuration. The /web folder is the web servable root and should be the document root for you web server configuration.

As it stands i’d imagine the whole Xibo code base, library, etc are web servable.

I think if you fix that issue you’ll find things start working again.

Thank you. Fixed the issue by modifying the Document root.

1 Like

No problem - i’m pleased you resolved it.